GUI dosen't work after joining a cluster

Jul 12, 2022
33
0
6
Hello everyone,

I tried to add a freshly installed Proxmox (which doesn't even have any VMs yet) to a cluster using the GUI. Unfortunately, this didn't work, and the GUI of the new Proxmox is not functioning anymore.

When I execute "journalctl -f," I receive the following error messages:


Code:
/etc/pve/local/pve-ssl.key: failed to load local private key (key_file or key) at /usr/share/perl5/PVE/APIServer/AnyEvent.pm line 1998.
[quorum] crit: quorum_initialize failed: 2
[confdb] crit: cmap_initialize failed: 2
[dcdb] crit: cpg_initialize failed: 2
[status] crit: cpg_initialize failed: 2

Furthermore, I cannot find a folder named "local" under "/etc/pve/"; instead, there is a link called "local" to "nodes/<my-hostname>."

Does anyone have an idea on how to solve this issue?

Thank you!
 
This solved my problem:

systemctl stop pve-cluster

systemctl stop corosync

pmxcfs -l

rm /etc/pve/corosync.conf

rm -fr /etc/corosync/*

killall pmxcfs

systemctl start pve-cluster

pvecm updatecerts --force
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!