GUI communication failure (0) on node fail

JohnnyD

Member
Mar 4, 2023
68
2
8
I have a 3 node cluster setup, one master and two nodes, one of my nodes is down currently, but the cluster page in the GUI on the remaining two now just times out with communication failure (0)

Is that expected behaviour, or should the page load OK showing the failed node as 'failed'?
 
this depends on how the api call fails exactly, if the server tries to reach the node but runs into a 30 second timeout it's possible to see the symptoms you describe
if the node is offline for sometime, it should fail faster and display a better error/info

i did work on improving that, but did not finish that yet
if you want you can open a bug here: https://bugzilla.proxmox.com to track that
 
  • Like
Reactions: JohnnyD
Hi Dominik, thanks you for the reply, FYI re amount of time, its been around 12 ish hours now its been down and still just timing out........
 
as i said that depends on which part exactly fails and how the network is setup. we will improve on that but no timeframe yet
 
  • Like
Reactions: JohnnyD

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!