[SOLVED] GRUB not updating with update-grub


New Member
Apr 20, 2020
Hi Guys,

I have a Problem with my setup.

Proxmox is running on a ZFS Mirrored Drive and now I want to change the Bootflags in GRUB. I want to add/change this line:
"GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on hugepagesz=1G default_hugepagesz=1G"

My Problem: update-grub is never taking any effect on grub.
I tried with adding these Bootflags to /etc/default/grub.d/XYZ.cfg, didnt help.

Anyone any Idea?
I think its updating some other config, but not the one which is used. If I type in the flags on boot manually (via e on grub) its working fine...

If you need any further information, please let me know :)

Thanks guys
Last edited:
Which version of Proxmox VE did you install initially and did you install it in BIOS/Legacy mode or UEFI?

Background: if it was installed with AFAIR 6.0 in UEFI mode it does not use GRUB as a bootloader but systemd-boot. More information and how to set boot flags for the kernel can be found in our documentation: https://pve.proxmox.com/pve-docs/pve-admin-guide.html#sysboot
  • Like
Reactions: minni
Hi aaron,
Thanks for your answer! Seems that this could be the problem.

I have the plain black GRUB Bootloader and also the file

cat /etc/kernel/pve-efiboot-uuids

is present on my system. So I would say I'm using the UEFI Boot with systemd-boot.
I will read into your linked documentation, I'll let you know when it worked.
So far, Thank you very much!

EDIT: Ah sorry, missed that: I'm using PVE 6.1-3 and it was installed initially with this version.

It worked! Thank you so much.

For other peoples which might have the same problem:
Ive just added the bootflags to /etc/kernel/cmdline
ran /etc/kernel/postinst.d/zz-pve-efiboot and rebooted - thats it.

Can be marked as solved
Last edited:
  • Like
Reactions: aaron
ran /etc/kernel/postinst.d/zz-pve-efiboot and rebooted - thats it.
For future readers, please run pve-efiboot-tool refresh as mentioned in the documentation instead of the snippet which is not guaranteed to stay the same in the future.

Can be marked as solved
You can do that by editing the first post and setting the title prefix accordingly. Thanks :)


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!