[SOLVED] Grub error booting installation usb-stick 5.4.1 (error: unknown filesystems)

Discussion in 'Proxmox VE: Installation and configuration' started by LeDidou, Jun 12, 2019.

  1. LeDidou

    LeDidou New Member

    Joined:
    Jun 12, 2019
    Messages:
    3
    Likes Received:
    0
    Hello,

    I have just created an USB-Stick using "proxmox-ve_5.4-1.iso"

    On the computer can't boot it and start installation.

    I have the messages
    error: unknown filesystems.
    ...
    (9x)
    Entering rescue mode...
    grub rescue>
    Investigation:
    1. The same usb-stick boot with no problem on my laptop (and installer start)
    2. I have disconnected all the SATA and M2 disk and get the same error
    3. I have disabled the SATA controler in Bios (previously in AHCI Mode) and get the same error
    4. In grub rescue mode, I have done some "ls" command and all seems ok : can see usb-stick containsInfor
    Information :
    1. My MB is a Asrock Pro 370 with Rysen 2700x , no disk connected on last try....

    I will try older version of ProxMox ?
    Search on debian Forum ?


    Thanks to help me
     
  2. LeDidou

    LeDidou New Member

    Joined:
    Jun 12, 2019
    Messages:
    3
    Likes Received:
    0
    New information ; On my laptop I have 2 boot option with this usb-key :
    • Legacy => it works
    • UEFI => same error as on my computer
    On my Computer, i have only one...
     
  3. LeDidou

    LeDidou New Member

    Joined:
    Jun 12, 2019
    Messages:
    3
    Likes Received:
    0
    [SOLVED]

    The problem was my USB stick was created with RUFUS_3.5 on windows and works in Legacy mode but NOT in UEFI Mode

    I create a new one on windows with BalenaEtcher-1.5.46 tools, and now the key is bootable in UEFI Mode, and my computer accepts it

    Perhaps an option to set in Rufus tools ...
     
    #3 LeDidou, Jun 12, 2019
    Last edited: Jun 12, 2019
  4. Stefan_R

    Stefan_R Proxmox Staff Member
    Staff Member

    Joined:
    Jun 4, 2019
    Messages:
    19
    Likes Received:
    4
    For reference: Rufus in the default configuration is not supported by Proxmox, since it writes it's own grub. Using Etcher (as you did) is the recommended way of flashing the installer, if you absolutely must use Rufus you can also enable "dd mode" in advanced settings, which should then work too.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice