[SOLVED] Grub error booting installation usb-stick 5.4.1 (error: unknown filesystems)


New Member
Jun 12, 2019

I have just created an USB-Stick using "proxmox-ve_5.4-1.iso"

On the computer can't boot it and start installation.

I have the messages
error: unknown filesystems.
Entering rescue mode...
grub rescue>
  1. The same usb-stick boot with no problem on my laptop (and installer start)
  2. I have disconnected all the SATA and M2 disk and get the same error
  3. I have disabled the SATA controler in Bios (previously in AHCI Mode) and get the same error
  4. In grub rescue mode, I have done some "ls" command and all seems ok : can see usb-stick containsInfor
Information :
  1. My MB is a Asrock Pro 370 with Rysen 2700x , no disk connected on last try....

I will try older version of ProxMox ?
Search on debian Forum ?

Thanks to help me
New information ; On my laptop I have 2 boot option with this usb-key :
  • Legacy => it works
  • UEFI => same error as on my computer
On my Computer, i have only one...

The problem was my USB stick was created with RUFUS_3.5 on windows and works in Legacy mode but NOT in UEFI Mode

I create a new one on windows with BalenaEtcher-1.5.46 tools, and now the key is bootable in UEFI Mode, and my computer accepts it

Perhaps an option to set in Rufus tools ...
Last edited:
For reference: Rufus in the default configuration is not supported by Proxmox, since it writes it's own grub. Using Etcher (as you did) is the recommended way of flashing the installer, if you absolutely must use Rufus you can also enable "dd mode" in advanced settings, which should then work too.
Hey Staff, I have just downloaded version 6 used BalenaEtcher, booted usig UEFI and getting the error that no cdrom found.

Why is this still such an issue for many people?
When trying to mount the USB: mount /dev/sdb4 /mnt failed: Invalid argument.

I even tried the DD method same error.
I just tried BalenaEtcher with the newest ISO from our downloads page - worked flawlessly with both Legacy and UEFI. Maybe check your boot configuration? "no cdrom found" sounds like you're not trying to boot off of a USB key? A bad flash drive can also cause issues.

Also I noticed you're trying to mount partition number 4; for me the boot files got installed to number 3.
I've also had issues with booting from proxmox installation usb (6.1). Posting this in case someone also comes such issue.

I've tried practically everything - rufus (both modes), etcher, dd, 2 (differently sized) usb sticks, 2 usb ports (back and front), forcing uefi/legacy/both boot modes... nothing. Spent almost a whole day. All I was getting is "boot failed" message. That's it.

The solution for me was to use "boot from file" instead of "boot from device" in the boot manager. In that menu I was easily able to navigate and select the "bootx64.efi" (or whatever it's called). At that time, the system was set to UEFI-only boot and the usb drive was flashed with dd.
Ran into the same problem using proxmox 7.0. Resolved the same way as OP. Was originally using rufus 3.17 but was running into the grub rescue issue when doing both UEFI and legacy options. Grabbed balenaEtcher 1.7.0 and it worked without issue. Sorry to revive from the dead but wanted to let people know it is still valid even with newer versions of all three things.
Last edited:
Switching from Rufus to BalenaEtcher also solved this problem for me. Thanks for keeping this thread alive and useful!
Just had that Problem too with Proxmox 7.1-2. The solution(for me at least) was using Rufus 3.17 in DD mode and forcing my PC to boot with CSM set to legacy only.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!