[SOLVED] Greyed-out nodes when configuring MD3800i


Renowned Member
Jul 19, 2012
Bologna, Italy
Hello all.
I'm having troubles with access to Dell MD3800i (iSCSI w/ multipath).
The nodes configured to use it gets marked with a grey question mark after some (random) time. Sometimes the running machines keep working, sometimes not.
I got the feeling that it's something workload-related: the nodes goes bad after I try to actually use the storage. Just having it configured w/ no VMs accessing it leaves the nodes "green" for a very long time (weeks or even months).
Does somebody have a Dell MD3800i configured and working and is willing to share the configuration?
Too bad there's no help from Dell, since Debian is unsupported (they only give very old rpm files for even older kernels).

*Edit*: I'm using Proxmox 5.3-11/d4907f84 (running kernel: 4.15.18-11-pve) ; on one node I tried updating to 5.3-11/d4907f84 (running kernel: 4.15.18-12-pve) but there's no change re/ this issue. I think it's not a network issue because I tried 3 different switches between MD3800i and my nodes, again w/ no changes.
Last edited:
I solved by upgrading the firmware in the MD3800i and simplifying the multipath.conf file to:
defaults {
  user_friendly_names yes
  find_multipaths     yes
blacklist {
  wwid .*
blacklist_exceptions {
  wwid  "xxx"
multipaths {
  multipath {
   wwid  "xxx"
   alias  mp_MD3800i
Now it seems to work.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!