Grew VM disk, moved and grew partition, VM doesn't see changes.

amtiskaw

Member
Mar 11, 2021
10
0
6
56
Hi

I have a Windows Server 2019 VM that I'm trying to give some more free disk space.

I shut the VM down, and grew the virtio disk by 60Gb

Then I booted the VM off a GParted ISO, moved the Windows rescue partition to the end of the disk so the free space was contiguous, and grew the Windows main partition.

1696213015180.png

Booting the VM into Windows Server 1019, I don't see the disk changes. Disk manager still see the rescue partition where it was, and the non-contiguous free space at the end of the disk.

1696212819729.png

Booting off an Ubuntu ISO, Disks shows the partition changes applied.

1696213303807.png

Can anyone explain what's going on here?

We're running 7.0.11 with local zfs pool storage only.
1696213522722.png
 
Found a solution here after more desperate searching:

After resizing and moving partitions, boot the VM, then shutdown with:
Code:
shutdown -s -t 0

The next restart of the VM should show the changes as applied.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!