GPU trouble


New Member
Oct 14, 2023

I'm having some trouble with my Proxmox setup. I'm running Proxmox on a HP Z440 workstation with a Quadro P1000 and a Quadro K2200 inside. The P1000 is working without trouble, but I can't seem to get the other card working.
When I run:
dmesg | grep -e DMAR -e IOMMU
it get an empty return (while the P1000 is working). When I try to link the K2200 to a VM, i get mixed errors in the syslog, which are:

pve kernel: vfio-pci 0000:02:00.0: BAR 3: can't reserve [mem 0xd0000000-0xd1ffffff 64bit pref]


pve kernel: vfio-pci 0000:02:00.0: No more image in the PCI ROM

I tried every hardware option possible, default bios/uefi bios, default display/virtio gpu, primary gpu on/off, but the results are the same.

My /etc/default/grub is

GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on iommu=pt pcie_aspm=off video=vesafbff video=efifbff"

I added 'pcie_aspm=off' after getting different errors. I added the video tags after searching for solutions, but nothing makes a difference.

What do these errors mean?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!