GPU Passthough Nvidia GTX 1050

Repsie

New Member
Jun 6, 2023
1
0
1
Disclaimer: This is my first time using proxmox and I'm this is all very new to me.

Im trying to set up a Viritual machine using proxmox. I went good untill I had to enable my GPU on the viritual machine and I followed this guide:
https://www.reddit.com/r/homelab/comments/b5xpua/the_ultimate_beginners_guide_to_gpu_passthrough/

Computer Specs:
Motherboard: MSI B85M-E45
CPU: Intel i5-4690
GPU: HP OEM Nvidia GTX 1050
RAM: 16GB
Storage: 250gb SSD

VM Config:

Code:
agent: 1
args: -cpu 'host,+kvm_pv_unhalt,+kvm_pv_eoi,hv_vendor_id=NV43FIX,kvm=off'
boot: order=scsi0;ide2;net0;ide0
cores: 1
cpu: host,hidden=1,flags=+pcid
hostpci0: 0000:01:00,pcie=1
ide0: local:iso/virtio-win-0.1.229.iso,media=cdrom,size=522284K
ide2: local:iso/Windows10.iso,media=cdrom,size=4468M
machine: pc-q35-3.1
memory: 2048
meta: creation-qemu=7.2.0,ctime=1685975880
name: Windows1
net0: virtio=32:33:B6:B8A:E6,bridge=vmbr0,firewall=1
numa: 0
ostype: win10
scsi0: local-lvm:vm-100-disk-0,cache=writeback,size=70G
scsihw: virtio-scsi-pci
smbios1: uuid=dc39f8e2-e1ee-433c-9697-1df9b6b80cd7
sockets: 1
vga: none

My Grub config:

Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on"

I have tried updating the drivers in the viritual machine when I download the drivers from nvidia it installs and sais it been installed. But when I start nvidia experience it sais "no drivers installed" when I then download and install drivers there is sais that I have the same versions of drivers as its going to install. I still press install and at the end it sais "installation has finished" But I still have the option to install drivers in geforce experience (and it stuck in that loop just reinstalling the same drivers if I look for updated once). It just keeps giving me the option for "Express Installation or Custom Installation"

I still have Error 43 in device manager under display adapters "NVIDIA GeForce GTX 1050" and its not showing in taskmanager.
I have also tried to adding my gpu .rom file like in the guide both with just getting it with GPU-Z and adding it to the correct directory with FileZilla. I also tried to patch the .rom file with "https://github.com/Matoking/NVIDIA-vBIOS-VFIO-Patcher". When I had the original file from GPU-Z it did nothing, and when I used the patcher I couldnt connect to the VM with remote access. I also added the "romfile=xxx.rom" in the hostpci0: when I had those.

Please let me know if there is anything I can provide that can be helpful understanding the problem.
Anything that could point me in the right directions would help a lot. Thanks in advance :)
 

Attachments

  • geforceexperience new.PNG
    geforceexperience new.PNG
    175.1 KB · Views: 11
  • geforceexperience install.PNG
    geforceexperience install.PNG
    120.6 KB · Views: 8
  • TaskManager.PNG
    TaskManager.PNG
    6.6 KB · Views: 10
  • 1050 error43.PNG
    1050 error43.PNG
    5.2 KB · Views: 10
A few things I can see: you probably want to give your windows VM more ram (at least 4GiB) and more cpu cores (at least 2). You also don't need to set hidden=1,flags=+pcid since your cpu Westermere, sandy bridge or ivy bridge.
Some resources I can give you are the PCIe passthrough docs [1] and our wiki [2] as well as some best-practices for windows [3]. Have a look through those and let me know if none of that helps :)

[1]: https://pve.proxmox.com/pve-docs/pve-admin-guide.html#qm_pci_passthrough
[2]: https://pve.proxmox.com/wiki/PCI_Passthrough
[3]: https://pve.proxmox.com/wiki/Windows_10_guest_best_practices
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!