Getting errors on apt update

elloco999

New Member
Aug 25, 2023
8
2
3
Hi all,

I just installed Proxmox VE 8 and tried to update the dependencies but I'm getting a 401 errors I don't know how to solve.
I'm following this guide so directly after installation I updated the apt repositories using these commands:
Code:
# Remove the enterprise repositories
rm /etc/apt/sources.list.d/pve-enterprise.list

# Add the community repositories
echo '# Proxmox community package repository' >> /etc/apt/sources.list
echo 'deb http://download.proxmox.com/debian/pve bookworm pve-no-subscription' >> /etc/apt/sources.list

Then I ran apt clean && apt update and got this result:
Code:
Hit:1 http://security.debian.org bookworm-security InRelease
Hit:2 http://ftp.nl.debian.org/debian bookworm InRelease                                            
Hit:3 http://ftp.nl.debian.org/debian bookworm-updates InRelease                                    
Get:4 http://download.proxmox.com/debian/pve bookworm InRelease [2,768 B]     
Err:5 https://enterprise.proxmox.com/debian/ceph-quincy bookworm InRelease    
  401  Unauthorized [IP: 212.224.123.70 443]
Get:6 http://download.proxmox.com/debian/pve bookworm/pve-no-subscription amd64 Packages [128 kB]
Reading package lists... Done      
E: Failed to fetch https://enterprise.proxmox.com/debian/ceph-quincy/dists/bookworm/InRelease  401  Unauthorized [IP: 212.224.123.70 443]
E: The repository 'https://enterprise.proxmox.com/debian/ceph-quincy bookworm InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

It looks like an enterprise repository so not sure why it is being queried in the first place as I thought I removed all enterprise repositories with that first command.
Can anybody help me get rid of that error?

Thanks,
elloco
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!