Getting error when upgrading proxmox v 6.x to v7.X

Jan 18, 2020
156
1
23
27
Hi,

I am getting the below error while proxmox upgrade.

Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
bsdmainutils ceph-mgr-modules-core cpp-8 cryptsetup-bin gcc-9-base libasan5 libisl19 libleveldb1d libmpx2 liboath0 libpython2-dev libpython2.7-dev libqrencode4
librabbitmq4 librdkafka1 librgw2 nvme-cli proxmox-archive-keyring proxmox-backup-client proxmox-backup-file-restore proxmox-backup-restore-image
pve-kernel-5.4.73-1-pve pve-kernel-5.4.78-2-pve python-ceph-argparse python-markupsafe python-pastedeploy-tpl python2-dev python2.7-dev python3-asn1crypto
python3-bcrypt python3-bs4 python3-ceph-argparse python3-ceph-common python3-cherrypy3 python3-dateutil python3-html5lib python3-logutils python3-lxml python3-paste
python3-pastedeploy python3-pastescript python3-pecan python3-pyinotify python3-repoze.lru python3-routes python3-simplegeneric python3-simplejson
python3-singledispatch python3-soupsieve python3-tempita python3-waitress python3-webencodings python3-webob python3-webtest python3-werkzeug python3-yaml qrencode
sudo
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
ceph ceph-base ceph-common ceph-mds ceph-mgr ceph-mon ceph-osd criu gcc-8 libgcc-8-dev libldb1 libpve-access-control libpve-cluster-api-perl libpve-guest-common-perl
libpve-storage-perl libpve-u2f-server-perl libpython-dev libpython-stdlib librados2-perl lxc-pve proxmox-ve pve-cluster pve-container pve-firewall pve-ha-manager
pve-manager pve-qemu-kvm python python-asn1crypto python-backports.functools-lru-cache python-bcrypt python-bs4 python-certifi python-cffi-backend python-chardet
python-cherrypy3 python-configparser python-cryptography python-dev python-dnspython python-enum34 python-formencode python-future python-idna python-ipaddr
python-ipaddress python-jwt python-logutils python-mako python-minimal python-openssl python-paste python-pastedeploy python-pecan python-prettytable python-protobuf
python-rados python-rbd python-requests python-rgw python-simplegeneric python-simplejson python-singledispatch python-soupsieve python-talloc python-tempita
python-urllib3 python-virtualenv python-waitress python-webob python-webtest python-werkzeug python3-cephfs python3-rados python3-rbd python3-rgw python3.7
qemu-server spiceterm
The following NEW packages will be installed:
alsa-topology-conf alsa-ucm-conf bind9-dnsutils bind9-libs bsdextrautils build-essential cpp-10 distro-info-data dpkg-dev fakeroot g++ g++-10 gcc-10 gcc-10-base
gcc-9-base libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libapt-pkg6.0 libasan6 libbpf0 libbrotli1 libc-devtools libcbor0 libcrypt-dev
libctf-nobfd0 libctf0 libdeflate0 libdns-export1110 libdns1110 libdpkg-perl libevent-2.1-7 libfakeroot libffi7 libfido2-1 libfile-fcntllock-perl libgcc-10-dev
libgcc-s1 libgd3 libglusterd0 libhogweed6 libicu67 libinih1 libip4tc2 libip6tc2 libipset13 libisc-export1105 libisc1105 libisl23 libjbig0 libjson-c5 libldb2
liblinear4 libmaxminddb0 libmd0 libmpdec3 libnettle8 libnsl-dev libnsl2 libnss-nis libnss-nisplus libopeniscsiusr libperl4-corelibs-perl libperl5.32 libprocps8
libpython3-dev libpython3.9 libpython3.9-dev libpython3.9-minimal libpython3.9-stdlib libreadline8 libstdc++-10-dev libtiff5 libtirpc-dev libuv1 libwebp6 libxpm4
libxxhash0 logsave lua-lpeg mailcap manpages-dev media-types ncal os-prober pci.ids perl-modules-5.32 python3-appdirs python3-dev python3-distlib python3-filelock
python3-importlib-metadata python3-ldb python3-more-itertools python3-pip python3-talloc python3-wheel python3-zipp python3.9 python3.9-dev python3.9-minimal
runit-helper systemd-timesyncd uuid-runtime zlib1g-dev
The following packages will be upgraded:
apparmor apt apt-listchanges apt-utils attr augeas-lenses base-files base-passwd bash bash-completion bc bind9-host binutils binutils-common
binutils-x86-64-linux-gnu bridge-utils bsd-mailx bsdmainutils bsdutils btrfs-progs busybox bzip2 ca-certificates cifs-utils console-setup console-setup-linux
coreutils cpio cpp cron cryptsetup-bin curl dash dbus debconf debconf-i18n debian-archive-keyring debian-faq debianutils diffutils dirmngr dmeventd dmidecode dmsetup
dnsutils doc-debian dosfstools dpkg dtach e2fsprogs ebtables efibootmgr eject ethtool faketime fdisk fdutils file findutils fontconfig fontconfig-config
fonts-dejavu-core fonts-font-awesome fonts-glyphicons-halflings fuse gcc gdbm-l10n gdisk genisoimage gettext-base git git-man glusterfs-client glusterfs-common gnupg
gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm gpgv grep groff-base grub-common grub-efi-amd64-bin grub-efi-ia32-bin grub-pc
grub-pc-bin grub2-common gzip hdparm hostname idn init init-system-helpers initramfs-tools initramfs-tools-core iproute2 ipset iptables iptables-persistent
iputils-ping isc-dhcp-client isc-dhcp-common iso-codes kbd keyboard-configuration keyutils klibc-utils kmod krb5-locales less libacl1 libacl1-dev libaio1
libanyevent-http-perl libanyevent-perl libapparmor1 libappconfig-perl libapt-pkg-perl libarchive13 libasan5 libasound2 libasound2-data libassuan0 libasyncns0
libatomic1 libattr1 libattr1-dev libaudit-common libaudit1 libaugeas0 libauthen-pam-perl libavahi-client3 libavahi-common-data libavahi-common3 libbabeltrace1
libbind9-161 libbinutils libblas3 libblkid1 libbsd0 libbz2-1.0 libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libcaca0 libcairo2 libcap-ng0 libcap2 libcap2-bin
libcc1-0 libclone-perl libcom-err2 libcommon-sense-perl libconvert-asn1-perl libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl
libcrypt-random-seed-perl libcrypt-ssleay-perl libcryptsetup12 libcups2 libcurl3-gnutls libcurl4 libdatrie1 libdb5.3 libdbi1 libdbus-1-3 libdebconfclient0
libdevmapper-event1.02.1 libdevmapper1.02.1 libdigest-hmac-perl libdw1 libedit2 libefiboot1 libefivar1 libelf1 libencode-locale-perl liberror-perl libestr0 libexpat1
libexpat1-dev libext2fs2 libfaketime libfastjson4 libfdisk1 libffi-dev libfile-chdir-perl libfile-listing-perl libfilesys-df-perl libflac8 libfontconfig1
libfreetype6 libfribidi0 libfstrm0 libfuse2 libfuse3-3 libgcrypt20 libgdbm-compat4 libgdbm6 libgeoip1 libgfapi0 libgfchangelog0 libgfortran5 libgfrpc0 libgfxdr0
libglib2.0-0 libglusterfs-dev libglusterfs0 libgmp10 libgnutls-openssl27 libgnutls30 libgnutlsxx28 libgomp1 libgoogle-perftools4 libgpg-error0 libgraphite2-3
libgssapi-krb5-2 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libharfbuzz0b libhtml-parser-perl libhtml-tagset-perl libhttp-cookies-perl libhttp-daemon-perl
libhttp-date-perl libhttp-message-perl libibverbs1 libice6 libidn11 libidn2-0 libio-html-perl libio-multiplex-perl libio-socket-ssl-perl libiptc0 libirs161
libisccc161 libisccfg163 libiscsi7 libisns0 libitm1 libjansson4 libjemalloc2 libjpeg62-turbo libjs-bootstrap libjs-jquery libjs-sphinxdoc libjs-underscore
libjson-perl libjson-xs-perl libk5crypto3 libkeyutils1 libklibc libkmod2 libkrb5-3 libkrb5support0 libksba8 libldap-2.4-2 libldap-common libleveldb1d
liblinux-inotify2-perl liblmdb0 liblocale-gettext-perl liblockfile-bin liblockfile1 liblognorm5 liblsan0 liblttng-ust-ctl4 liblttng-ust0 liblua5.3-0 liblvm2cmd2.03
liblwp-mediatypes-perl liblwp-protocol-https-perl liblwres161 liblz4-1 liblzma5 liblzo2-2 libmagic-mgc libmagic1 libmath-random-isaac-perl libmime-base32-perl
libmnl0 libmount1 libmpc3 libmpfr6 libncurses6 libncursesw6 libnet-dbus-perl libnet-dns-perl libnet-http-perl libnet-ldap-perl libnet-ssleay-perl
libnetfilter-conntrack3 libnetfilter-log1 libnewt0.52 libnfsidmap2 libnftnl11 libnghttp2-14 libnl-3-200 libnl-route-3-200 libnpth0 libnspr4 libnss-systemd libnss3
libnuma1 liboath0 libogg0 libopus0 liborc-0.4-0 libp11-kit0 libpam-modules libpam-modules-bin libpam-runtime libpam-systemd libpam0g libpango-1.0-0
libpangocairo-1.0-0 libpangoft2-1.0-0 libparted2 libpcap0.8 libpci3 libpcre2-8-0 libpcre3 libpipeline1 libpixman-1-0 libpng16-16 libpopt0 libprotobuf-c1 libpsl5
libpulse0 libpython2-dev libpython2-stdlib libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libqrencode4 libquadmath0
librabbitmq4 librdkafka1 librdmacm1 librrd8 librrds-perl librtmp1 libsasl2-2 libsasl2-modules-db libsdl1.2debian libseccomp2 libselinux1 libsemanage-common
libsemanage1 libsepol1 libslang2 libsmartcols1 libsmbclient libsnappy1v5 libsndfile1 libspice-server1 libsqlite3-0 libss2 libssh2-1 libssl-dev libssl1.1
libstatgrab10 libstdc++6 libsystemd0 libtalloc2 libtasn1-6 libtcmalloc-minimal4 libtdb1 libtemplate-perl libterm-readline-gnu-perl libtevent0 libtext-charwidth-perl
libtext-iconv-perl libtext-wrapi18n-perl libthai-data libthai0 libtimedate-perl libtinfo6 libtirpc-common libtirpc3 libtsan0 libtypes-serialiser-perl libu2f-server0
libubsan1 libuchardet0 libudev1 libunistring2 libunwind8 liburcu6 liburi-perl libusb-1.0-0 libusbredirparser1 libuuid-perl libuuid1 libvorbis0a libvorbisenc2
libwbclient0 libwrap0 libwww-perl libx11-6 libx11-data libx11-xcb1 libxau6 libxcb-render0 libxcb-shm0 libxcb1 libxext6 libxi6 libxml-libxml-perl
libxml-namespacesupport-perl libxml-parser-perl libxml-sax-base-perl libxml-sax-perl libxml-twig-perl libxml2 libxslt1.1 libxtables12 libyaml-0-2
libyaml-libyaml-perl libzstd1 linux-libc-dev locales login logrotate lsb-base lsof lvm2 lxcfs lynx lynx-common lzop make man-db manpages mawk memtest86+ mime-support
monitoring-plugins-basic monitoring-plugins-common mount nagios-nrpe-server nano ncurses-base ncurses-bin ncurses-term netbase netcat-traditional
netfilter-persistent nfs-common nmap nmap-common numactl nvme-cli open-iscsi openssh-client openssh-server openssh-sftp-server openssl parted passwd patch pciutils
perl perl-base perl-openssl-defaults pinentry-curses postfix procps psmisc python-apt-common python-markupsafe python-pastedeploy-tpl python-pip-whl
python-pkg-resources python-six python2 python2-dev python2-minimal python2.7 python2.7-dev python2.7-minimal python3 python3-apt python3-asn1crypto python3-bcrypt
python3-bs4 python3-certifi python3-cffi-backend python3-chardet python3-cherrypy3 python3-cryptography python3-dateutil python3-debconf python3-debian
python3-debianbts python3-distutils python3-html5lib python3-httplib2 python3-idna python3-jwt python3-lib2to3 python3-logutils python3-lxml python3-mako
python3-markupsafe python3-minimal python3-openssl python3-paste python3-pastedeploy python3-pastescript python3-pecan python3-pkg-resources python3-prettytable
python3-pycurl python3-pyinotify python3-pysimplesoap python3-reportbug python3-repoze.lru python3-requests python3-routes python3-setuptools python3-simplegeneric
python3-simplejson python3-singledispatch python3-six python3-soupsieve python3-tempita python3-urllib3 python3-virtualenv python3-waitress python3-webencodings
python3-webob python3-webtest python3-werkzeug python3-yaml qrencode readline-common reportbug rpcbind rrdcached rsync rsyslog samba-common samba-libs sensible-utils
smbclient socat sqlite3 ssh ssl-cert strace sudo systemd systemd-sysv sysvinit-utils tar tasksel tasksel-data tcpdump telnet thin-provisioning-tools time traceroute
tzdata ucf udev uidmap update-inetd usb.ids usbutils util-linux vim-common vim-tiny virtualenv wamerican wget whiptail wipe x11-common xfsprogs xinetd xkb-data
xsltproc xxd xz-utils zlib1g zstd
596 upgraded, 105 newly installed, 79 to remove and 0 not upgraded.
Need to get 0 B/315 MB of archives.
After this operation, 286 MB disk space will be freed.
Do you want to continue? [Y/n] Y
W: (pve-apt-hook) !! WARNING !!
W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
W: (pve-apt-hook)
W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from your system, run the following command
W: (pve-apt-hook) touch '/please-remove-proxmox-ve'
W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package
W: (pve-apt-hook) and repeat your apt invocation.
W: (pve-apt-hook)
W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify
W: (pve-apt-hook) - your APT repository settings
W: (pve-apt-hook) - that you are using 'apt full-upgrade' to upgrade your system
E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook

Looking forward to your reply.

Regards,
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,520
906
163
Please post the full output of:

> apt update

> apt dist-upgrade
 
Jan 18, 2020
156
1
23
27
root@px-sg2-n1:~# apt update
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://ftp.debian.org/debian buster InRelease
Hit:3 http://ftp.debian.org/debian buster-updates InRelease
Hit:4 http://download.proxmox.com/debian/ceph-octopus buster InRelease
Hit:5 http://download.proxmox.com/debian/pve buster InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.


root@px-sg2-n1:~# apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
pve-kernel-5.4.73-1-pve pve-kernel-5.4.78-2-pve
python-backports.functools-lru-cache python-bcrypt python-bs4
python-ceph-argparse python-cherrypy3 python-dnspython python-formencode
python-jwt python-logutils python-mako python-markupsafe python-paste
python-pastedeploy python-pecan python-rgw python-simplegeneric
python-simplejson python-singledispatch python-soupsieve python-tempita
python-waitress python-webob python-webtest python-werkzeug
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,520
906
163
We are getting this error when we try to upgrade the proxmox to 7.X
Which Error? You last post do not show any error, just the apt update output from a buster installation with no error.
 
Jan 18, 2020
156
1
23
27
Hi,

The error still persists.

>Which Error? You last post do not show any error, just the apt update output from a buster installation with no error.

It is because we have changed the repository to the buster.

upon checking using the repository "bullseye" the error is still there

Thank you.
 
Jan 18, 2020
156
1
23
27
root@px-sg2-n1:~# apt update
Get:1 http://security.debian.org bullseye-security InRelease [44.1 kB]
Get:2 http://security.debian.org bullseye-security/main amd64 Packages [96.2 kB]
Get:3 http://security.debian.org bullseye-security/main Translation-en [59.7 kB]
Get:4 http://ftp.debian.org/debian bullseye InRelease [116 kB]
Hit:5 http://download.proxmox.com/debian/ceph-octopus buster InRelease
Hit:6 http://download.proxmox.com/debian/pve buster InRelease
Get:7 http://ftp.debian.org/debian bullseye-updates InRelease [39.4 kB]
Get:8 http://ftp.debian.org/debian bullseye/main amd64 Packages [8,180 kB]
Get:9 http://ftp.debian.org/debian bullseye/main Translation-en [6,241 kB]
Get:10 http://ftp.debian.org/debian bullseye/contrib amd64 Packages [50.5 kB]
Get:11 http://ftp.debian.org/debian bullseye/contrib Translation-en [46.9 kB]
Get:12 http://ftp.debian.org/debian bullseye-updates/main amd64 Packages [2,592 B]
Get:13 http://ftp.debian.org/debian bullseye-updates/main Translation-en [2,343 B]
Fetched 14.9 MB in 3s (5,001 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
596 packages can be upgraded. Run 'apt list --upgradable' to see them.


root@px-sg2-n1:~# apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
bsdmainutils ceph-mgr-modules-core cpp-8 cryptsetup-bin gcc-9-base libasan5 libisl19 libleveldb1d libmpx2 liboath0
libpython2-dev libpython2.7-dev libqrencode4 librabbitmq4 librdkafka1 librgw2 nvme-cli proxmox-archive-keyring
proxmox-backup-client proxmox-backup-file-restore proxmox-backup-restore-image pve-kernel-5.4.73-1-pve
pve-kernel-5.4.78-2-pve python-ceph-argparse python-markupsafe python-pastedeploy-tpl python2-dev python2.7-dev
python3-asn1crypto python3-bcrypt python3-bs4 python3-ceph-argparse python3-ceph-common python3-cherrypy3
python3-dateutil python3-html5lib python3-logutils python3-lxml python3-paste python3-pastedeploy
python3-pastescript python3-pecan python3-pyinotify python3-repoze.lru python3-routes python3-simplegeneric
python3-simplejson python3-singledispatch python3-soupsieve python3-tempita python3-waitress python3-webencodings
python3-webob python3-webtest python3-werkzeug python3-yaml qrencode sudo
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
ceph ceph-base ceph-common ceph-mds ceph-mgr ceph-mon ceph-osd criu gcc-8 libgcc-8-dev libldb1 libpve-access-control
libpve-cluster-api-perl libpve-guest-common-perl libpve-storage-perl libpve-u2f-server-perl libpython-dev
libpython-stdlib librados2-perl lxc-pve proxmox-ve pve-cluster pve-container pve-firewall pve-ha-manager pve-manager
pve-qemu-kvm python python-asn1crypto python-backports.functools-lru-cache python-bcrypt python-bs4 python-certifi
python-cffi-backend python-chardet python-cherrypy3 python-configparser python-cryptography python-dev
python-dnspython python-enum34 python-formencode python-future python-idna python-ipaddr python-ipaddress python-jwt
python-logutils python-mako python-minimal python-openssl python-paste python-pastedeploy python-pecan
python-prettytable python-protobuf python-rados python-rbd python-requests python-rgw python-simplegeneric
python-simplejson python-singledispatch python-soupsieve python-talloc python-tempita python-urllib3
python-virtualenv python-waitress python-webob python-webtest python-werkzeug python3-cephfs python3-rados
python3-rbd python3-rgw python3.7 qemu-server spiceterm
The following NEW packages will be installed:
alsa-topology-conf alsa-ucm-conf bind9-dnsutils bind9-libs bsdextrautils build-essential cpp-10 distro-info-data
dpkg-dev fakeroot g++ g++-10 gcc-10 gcc-10-base gcc-9-base libalgorithm-diff-perl libalgorithm-diff-xs-perl
libalgorithm-merge-perl libapt-pkg6.0 libasan6 libbpf0 libbrotli1 libc-devtools libcbor0 libcrypt-dev libctf-nobfd0
libctf0 libdeflate0 libdns-export1110 libdns1110 libdpkg-perl libevent-2.1-7 libfakeroot libffi7 libfido2-1
libfile-fcntllock-perl libgcc-10-dev libgcc-s1 libgd3 libglusterd0 libhogweed6 libicu67 libinih1 libip4tc2 libip6tc2
libipset13 libisc-export1105 libisc1105 libisl23 libjbig0 libjson-c5 libldb2 liblinear4 libmaxminddb0 libmd0
libmpdec3 libnettle8 libnsl-dev libnsl2 libnss-nis libnss-nisplus libopeniscsiusr libperl4-corelibs-perl libperl5.32
libprocps8 libpython3-dev libpython3.9 libpython3.9-dev libpython3.9-minimal libpython3.9-stdlib libreadline8
libstdc++-10-dev libtiff5 libtirpc-dev libuv1 libwebp6 libxpm4 libxxhash0 logsave lua-lpeg mailcap manpages-dev
media-types ncal os-prober pci.ids perl-modules-5.32 python3-appdirs python3-dev python3-distlib python3-filelock
python3-importlib-metadata python3-ldb python3-more-itertools python3-pip python3-talloc python3-wheel python3-zipp
python3.9 python3.9-dev python3.9-minimal runit-helper systemd-timesyncd uuid-runtime zlib1g-dev
The following packages will be upgraded:
apparmor apt apt-listchanges apt-utils attr augeas-lenses base-files base-passwd bash bash-completion bc bind9-host
binutils binutils-common binutils-x86-64-linux-gnu bridge-utils bsd-mailx bsdmainutils bsdutils btrfs-progs busybox
bzip2 ca-certificates cifs-utils console-setup console-setup-linux coreutils cpio cpp cron cryptsetup-bin curl dash
dbus debconf debconf-i18n debian-archive-keyring debian-faq debianutils diffutils dirmngr dmeventd dmidecode dmsetup
dnsutils doc-debian dosfstools dpkg dtach e2fsprogs ebtables efibootmgr eject ethtool faketime fdisk fdutils file
findutils fontconfig fontconfig-config fonts-dejavu-core fonts-font-awesome fonts-glyphicons-halflings fuse gcc
gdbm-l10n gdisk genisoimage gettext-base git git-man glusterfs-client glusterfs-common gnupg gnupg-l10n gnupg-utils
gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm gpgv grep groff-base grub-common grub-efi-amd64-bin
grub-efi-ia32-bin grub-pc grub-pc-bin grub2-common gzip hdparm hostname idn init init-system-helpers initramfs-tools
initramfs-tools-core iproute2 ipset iptables iptables-persistent iputils-ping isc-dhcp-client isc-dhcp-common
iso-codes kbd keyboard-configuration keyutils klibc-utils kmod krb5-locales less libacl1 libacl1-dev libaio1
libanyevent-http-perl libanyevent-perl libapparmor1 libappconfig-perl libapt-pkg-perl libarchive13 libasan5
libasound2 libasound2-data libassuan0 libasyncns0 libatomic1 libattr1 libattr1-dev libaudit-common libaudit1
libaugeas0 libauthen-pam-perl libavahi-client3 libavahi-common-data libavahi-common3 libbabeltrace1 libbind9-161
libbinutils libblas3 libblkid1 libbsd0 libbz2-1.0 libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libcaca0 libcairo2
libcap-ng0 libcap2 libcap2-bin libcc1-0 libclone-perl libcom-err2 libcommon-sense-perl libconvert-asn1-perl
libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcrypt-random-seed-perl
libcrypt-ssleay-perl libcryptsetup12 libcups2 libcurl3-gnutls libcurl4 libdatrie1 libdb5.3 libdbi1 libdbus-1-3
libdebconfclient0 libdevmapper-event1.02.1 libdevmapper1.02.1 libdigest-hmac-perl libdw1 libedit2 libefiboot1
libefivar1 libelf1 libencode-locale-perl liberror-perl libestr0 libexpat1 libexpat1-dev libext2fs2 libfaketime
libfastjson4 libfdisk1 libffi-dev libfile-chdir-perl libfile-listing-perl libfilesys-df-perl libflac8 libfontconfig1
libfreetype6 libfribidi0 libfstrm0 libfuse2 libfuse3-3 libgcrypt20 libgdbm-compat4 libgdbm6 libgeoip1 libgfapi0
libgfchangelog0 libgfortran5 libgfrpc0 libgfxdr0 libglib2.0-0 libglusterfs-dev libglusterfs0 libgmp10
libgnutls-openssl27 libgnutls30 libgnutlsxx28 libgomp1 libgoogle-perftools4 libgpg-error0 libgraphite2-3
libgssapi-krb5-2 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libharfbuzz0b libhtml-parser-perl
libhtml-tagset-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl libhttp-message-perl libibverbs1
libice6 libidn11 libidn2-0 libio-html-perl libio-multiplex-perl libio-socket-ssl-perl libiptc0 libirs161 libisccc161
libisccfg163 libiscsi7 libisns0 libitm1 libjansson4 libjemalloc2 libjpeg62-turbo libjs-bootstrap libjs-jquery
libjs-sphinxdoc libjs-underscore libjson-perl libjson-xs-perl libk5crypto3 libkeyutils1 libklibc libkmod2 libkrb5-3
libkrb5support0 libksba8 libldap-2.4-2 libldap-common libleveldb1d liblinux-inotify2-perl liblmdb0
liblocale-gettext-perl liblockfile-bin liblockfile1 liblognorm5 liblsan0 liblttng-ust-ctl4 liblttng-ust0 liblua5.3-0
liblvm2cmd2.03 liblwp-mediatypes-perl liblwp-protocol-https-perl liblwres161 liblz4-1 liblzma5 liblzo2-2
libmagic-mgc libmagic1 libmath-random-isaac-perl libmime-base32-perl libmnl0 libmount1 libmpc3 libmpfr6 libncurses6
libncursesw6 libnet-dbus-perl libnet-dns-perl libnet-http-perl libnet-ldap-perl libnet-ssleay-perl
libnetfilter-conntrack3 libnetfilter-log1 libnewt0.52 libnfsidmap2 libnftnl11 libnghttp2-14 libnl-3-200
libnl-route-3-200 libnpth0 libnspr4 libnss-systemd libnss3 libnuma1 liboath0 libogg0 libopus0 liborc-0.4-0
libp11-kit0 libpam-modules libpam-modules-bin libpam-runtime libpam-systemd libpam0g libpango-1.0-0
libpangocairo-1.0-0 libpangoft2-1.0-0 libparted2 libpcap0.8 libpci3 libpcre2-8-0 libpcre3 libpipeline1 libpixman-1-0
libpng16-16 libpopt0 libprotobuf-c1 libpsl5 libpulse0 libpython2-dev libpython2-stdlib libpython2.7 libpython2.7-dev
libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libqrencode4 libquadmath0 librabbitmq4 librdkafka1
librdmacm1 librrd8 librrds-perl librtmp1 libsasl2-2 libsasl2-modules-db libsdl1.2debian libseccomp2 libselinux1
libsemanage-common libsemanage1 libsepol1 libslang2 libsmartcols1 libsmbclient libsnappy1v5 libsndfile1
libspice-server1 libsqlite3-0 libss2 libssh2-1 libssl-dev libssl1.1 libstatgrab10 libstdc++6 libsystemd0 libtalloc2
libtasn1-6 libtcmalloc-minimal4 libtdb1 libtemplate-perl libterm-readline-gnu-perl libtevent0 libtext-charwidth-perl
libtext-iconv-perl libtext-wrapi18n-perl libthai-data libthai0 libtimedate-perl libtinfo6 libtirpc-common libtirpc3
libtsan0 libtypes-serialiser-perl libu2f-server0 libubsan1 libuchardet0 libudev1 libunistring2 libunwind8 liburcu6
liburi-perl libusb-1.0-0 libusbredirparser1 libuuid-perl libuuid1 libvorbis0a libvorbisenc2 libwbclient0 libwrap0
libwww-perl libx11-6 libx11-data libx11-xcb1 libxau6 libxcb-render0 libxcb-shm0 libxcb1 libxext6 libxi6
libxml-libxml-perl libxml-namespacesupport-perl libxml-parser-perl libxml-sax-base-perl libxml-sax-perl
libxml-twig-perl libxml2 libxslt1.1 libxtables12 libyaml-0-2 libyaml-libyaml-perl libzstd1 linux-libc-dev locales
login logrotate lsb-base lsof lvm2 lxcfs lynx lynx-common lzop make man-db manpages mawk memtest86+ mime-support
monitoring-plugins-basic monitoring-plugins-common mount nagios-nrpe-server nano ncurses-base ncurses-bin
ncurses-term netbase netcat-traditional netfilter-persistent nfs-common nmap nmap-common numactl nvme-cli open-iscsi
openssh-client openssh-server openssh-sftp-server openssl parted passwd patch pciutils perl perl-base
perl-openssl-defaults pinentry-curses postfix procps psmisc python-apt-common python-markupsafe
python-pastedeploy-tpl python-pip-whl python-pkg-resources python-six python2 python2-dev python2-minimal python2.7
python2.7-dev python2.7-minimal python3 python3-apt python3-asn1crypto python3-bcrypt python3-bs4 python3-certifi
python3-cffi-backend python3-chardet python3-cherrypy3 python3-cryptography python3-dateutil python3-debconf
python3-debian python3-debianbts python3-distutils python3-html5lib python3-httplib2 python3-idna python3-jwt
python3-lib2to3 python3-logutils python3-lxml python3-mako python3-markupsafe python3-minimal python3-openssl
python3-paste python3-pastedeploy python3-pastescript python3-pecan python3-pkg-resources python3-prettytable
python3-pycurl python3-pyinotify python3-pysimplesoap python3-reportbug python3-repoze.lru python3-requests
python3-routes python3-setuptools python3-simplegeneric python3-simplejson python3-singledispatch python3-six
python3-soupsieve python3-tempita python3-urllib3 python3-virtualenv python3-waitress python3-webencodings
python3-webob python3-webtest python3-werkzeug python3-yaml qrencode readline-common reportbug rpcbind rrdcached
rsync rsyslog samba-common samba-libs sensible-utils smbclient socat sqlite3 ssh ssl-cert strace sudo systemd
systemd-sysv sysvinit-utils tar tasksel tasksel-data tcpdump telnet thin-provisioning-tools time traceroute tzdata
ucf udev uidmap update-inetd usb.ids usbutils util-linux vim-common vim-tiny virtualenv wamerican wget whiptail wipe
x11-common xfsprogs xinetd xkb-data xsltproc xxd xz-utils zlib1g zstd
596 upgraded, 105 newly installed, 79 to remove and 0 not upgraded.
Need to get 0 B/315 MB of archives.
After this operation, 286 MB disk space will be freed.
Do you want to continue? [Y/n] yes
W: (pve-apt-hook) !! WARNING !!
W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
W: (pve-apt-hook)
W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from your system, run the following command
W: (pve-apt-hook) touch '/please-remove-proxmox-ve'
W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package
W: (pve-apt-hook) and repeat your apt invocation.
W: (pve-apt-hook)
W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify
W: (pve-apt-hook) - your APT repository settings
W: (pve-apt-hook) - that you are using 'apt full-upgrade' to upgrade your system
E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,520
906
163
root@px-sg2-n1:~# apt update
Get:1 http://security.debian.org bullseye-security InRelease [44.1 kB]
Get:2 http://security.debian.org bullseye-security/main amd64 Packages [96.2 kB]
Get:3 http://security.debian.org bullseye-security/main Translation-en [59.7 kB]
Get:4 http://ftp.debian.org/debian bullseye InRelease [116 kB]
Hit:5 http://download.proxmox.com/debian/ceph-octopus buster InRelease
Hit:6 http://download.proxmox.com/debian/pve buster InRelease

You cannot mix bullseye with buster. I really suggest again to read the upgrade guide in full detail.

Get:7 http://ftp.debian.org/debian bullseye-updates InRelease [39.4 kB]
Get:8 http://ftp.debian.org/debian bullseye/main amd64 Packages [8,180 kB]
Get:9 http://ftp.debian.org/debian bullseye/main Translation-en [6,241 kB]
Get:10 http://ftp.debian.org/debian bullseye/contrib amd64 Packages [50.5 kB]
Get:11 http://ftp.debian.org/debian bullseye/contrib Translation-en [46.9 kB]
Get:12 http://ftp.debian.org/debian bullseye-updates/main amd64 Packages [2,592 B]
Get:13 http://ftp.debian.org/debian bullseye-updates/main Translation-en [2,343 B]
 
Jan 18, 2020
156
1
23
27
root@px-sg2-n1:~# apt update
Hit:1 http://security.debian.org bullseye-security InRelease
Hit:2 http://ftp.debian.org/debian bullseye InRelease
Get:3 http://ftp.debian.org/debian bullseye-updates InRelease [39.4 kB]
Hit:4 http://download.proxmox.com/debian/ceph-octopus bullseye InRelease
Fetched 39.4 kB in 1s (61.7 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
616 packages can be upgraded. Run 'apt list --upgradable' to see them.



root@px-sg2-n1:~# apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
bsdmainutils cpp-8 gcc-9-base libasan5 libisl19 libmpx2 libpython2-dev libpython2.7-dev libqrencode4
proxmox-archive-keyring proxmox-backup-client proxmox-backup-file-restore proxmox-backup-restore-image
pve-kernel-5.4.73-1-pve pve-kernel-5.4.78-2-pve python-ceph-argparse python-markupsafe python2-dev python2.7-dev
python3-asn1crypto qrencode
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
criu gcc-8 libgcc-8-dev libldb1 libpve-access-control libpve-cluster-api-perl libpve-guest-common-perl
libpve-storage-perl libpve-u2f-server-perl libpython-dev libpython-stdlib librados2-perl lxc-pve proxmox-ve
pve-cluster pve-container pve-firewall pve-ha-manager pve-manager python python-asn1crypto
python-backports.functools-lru-cache python-bcrypt python-bs4 python-certifi python-cffi-backend python-chardet
python-cherrypy3 python-configparser python-cryptography python-dev python-dnspython python-enum34 python-formencode
python-future python-idna python-ipaddr python-ipaddress python-jwt python-logutils python-mako python-minimal
python-openssl python-paste python-pastedeploy python-pecan python-prettytable python-protobuf python-rados
python-rbd python-requests python-rgw python-simplegeneric python-simplejson python-singledispatch python-soupsieve
python-talloc python-tempita python-urllib3 python-virtualenv python-waitress python-webob python-webtest
python-werkzeug python3.7 qemu-server
The following NEW packages will be installed:
alsa-topology-conf alsa-ucm-conf bind9-dnsutils bind9-libs bsdextrautils build-essential cpp-10 distro-info-data
dpkg-dev fakeroot g++ g++-10 gcc-10 gcc-10-base gcc-9-base libalgorithm-diff-perl libalgorithm-diff-xs-perl
libalgorithm-merge-perl libapt-pkg6.0 libasan6 libbpf0 libbrotli1 libc-devtools libcbor0 libcrypt-dev libctf-nobfd0
libctf0 libdeflate0 libdns-export1110 libdns1110 libdpkg-perl libevent-2.1-7 libfakeroot libffi7 libfido2-1
libfile-fcntllock-perl libgcc-10-dev libgcc-s1 libgd3 libglusterd0 libhogweed6 libicu67 libinih1 libip4tc2 libip6tc2
libipset13 libisc-export1105 libisc1105 libisl23 libjbig0 libjson-c5 libldb2 liblinear4 libmaxminddb0 libmd0
libmpdec3 libnettle8 libnsl-dev libnsl2 libnss-nis libnss-nisplus libopeniscsiusr libperl4-corelibs-perl libperl5.32
libprocps8 libpython3-dev libpython3.9 libpython3.9-dev libpython3.9-minimal libpython3.9-stdlib libreadline8
libstdc++-10-dev libtiff5 libtirpc-dev libuv1 libwebp6 libxpm4 libxxhash0 logsave lua-lpeg mailcap manpages-dev
media-types ncal os-prober pci.ids perl-modules-5.32 python3-appdirs python3-dev python3-distlib python3-filelock
python3-importlib-metadata python3-ldb python3-more-itertools python3-pip python3-talloc python3-wheel python3-zipp
python3.9 python3.9-dev python3.9-minimal runit-helper systemd-timesyncd uuid-runtime zlib1g-dev
The following packages will be upgraded:
apparmor apt apt-listchanges apt-utils attr augeas-lenses base-files base-passwd bash bash-completion bc bind9-host
binutils binutils-common binutils-x86-64-linux-gnu bridge-utils bsd-mailx bsdmainutils bsdutils btrfs-progs busybox
bzip2 ca-certificates ceph ceph-base ceph-common ceph-fuse ceph-mds ceph-mgr ceph-mgr-modules-core ceph-mon ceph-osd
cifs-utils console-setup console-setup-linux coreutils cpio cpp cron cryptsetup-bin curl dash dbus debconf
debconf-i18n debian-archive-keyring debian-faq debianutils diffutils dirmngr dmeventd dmidecode dmsetup dnsutils
doc-debian dosfstools dpkg dtach e2fsprogs ebtables efibootmgr eject ethtool faketime fdisk fdutils file findutils
fontconfig fontconfig-config fonts-dejavu-core fonts-font-awesome fonts-glyphicons-halflings fuse gcc gdbm-l10n
gdisk genisoimage gettext-base git git-man glusterfs-client glusterfs-common gnupg gnupg-l10n gnupg-utils gpg
gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm gpgv grep groff-base grub-common grub-efi-amd64-bin
grub-efi-ia32-bin grub-pc grub-pc-bin grub2-common gzip hdparm hostname idn init init-system-helpers initramfs-tools
initramfs-tools-core iproute2 ipset iptables iptables-persistent iputils-ping isc-dhcp-client isc-dhcp-common
iso-codes kbd keyboard-configuration keyutils klibc-utils kmod krb5-locales less libacl1 libacl1-dev libaio1
libanyevent-http-perl libanyevent-perl libapparmor1 libappconfig-perl libapt-pkg-perl libarchive13 libasan5
libasound2 libasound2-data libassuan0 libasyncns0 libatomic1 libattr1 libattr1-dev libaudit-common libaudit1
libaugeas0 libauthen-pam-perl libavahi-client3 libavahi-common-data libavahi-common3 libbabeltrace1 libbind9-161
libbinutils libblas3 libblkid1 libbsd0 libbz2-1.0 libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libcaca0 libcairo2
libcap-ng0 libcap2 libcap2-bin libcc1-0 libcephfs2 libclone-perl libcom-err2 libcommon-sense-perl
libconvert-asn1-perl libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl
libcrypt-random-seed-perl libcrypt-ssleay-perl libcryptsetup12 libcups2 libcurl3-gnutls libcurl4 libdatrie1 libdb5.3
libdbi1 libdbus-1-3 libdebconfclient0 libdevmapper-event1.02.1 libdevmapper1.02.1 libdigest-hmac-perl libdw1
libedit2 libefiboot1 libefivar1 libelf1 libencode-locale-perl liberror-perl libestr0 libexpat1 libexpat1-dev
libext2fs2 libfaketime libfastjson4 libfdisk1 libffi-dev libfile-chdir-perl libfile-listing-perl libfilesys-df-perl
libflac8 libfontconfig1 libfreetype6 libfribidi0 libfstrm0 libfuse2 libfuse3-3 libgcrypt20 libgdbm-compat4 libgdbm6
libgeoip1 libgfapi0 libgfchangelog0 libgfortran5 libgfrpc0 libgfxdr0 libglib2.0-0 libglusterfs-dev libglusterfs0
libgmp10 libgnutls-openssl27 libgnutls30 libgnutlsxx28 libgomp1 libgoogle-perftools4 libgpg-error0 libgraphite2-3
libgssapi-krb5-2 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libharfbuzz0b libhtml-parser-perl
libhtml-tagset-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl libhttp-message-perl libibverbs1
libice6 libidn11 libidn2-0 libio-html-perl libio-multiplex-perl libio-socket-ssl-perl libiptc0 libirs161 libisccc161
libisccfg163 libiscsi7 libisns0 libitm1 libjansson4 libjemalloc2 libjpeg62-turbo libjs-bootstrap libjs-jquery
libjs-sphinxdoc libjs-underscore libjson-perl libjson-xs-perl libk5crypto3 libkeyutils1 libklibc libkmod2 libkrb5-3
libkrb5support0 libksba8 libldap-2.4-2 libldap-common libleveldb1d liblinux-inotify2-perl liblmdb0
liblocale-gettext-perl liblockfile-bin liblockfile1 liblognorm5 liblsan0 liblttng-ust-ctl4 liblttng-ust0 liblua5.3-0
liblvm2cmd2.03 liblwp-mediatypes-perl liblwp-protocol-https-perl liblwres161 liblz4-1 liblzma5 liblzo2-2
libmagic-mgc libmagic1 libmath-random-isaac-perl libmime-base32-perl libmnl0 libmount1 libmpc3 libmpfr6 libncurses6
libncursesw6 libnet-dbus-perl libnet-dns-perl libnet-http-perl libnet-ldap-perl libnet-ssleay-perl
libnetfilter-conntrack3 libnetfilter-log1 libnewt0.52 libnfsidmap2 libnftnl11 libnghttp2-14 libnl-3-200
libnl-route-3-200 libnpth0 libnspr4 libnss-systemd libnss3 libnuma1 liboath0 libogg0 libopus0 liborc-0.4-0
libp11-kit0 libpam-modules libpam-modules-bin libpam-runtime libpam-systemd libpam0g libpango-1.0-0
libpangocairo-1.0-0 libpangoft2-1.0-0 libparted2 libpcap0.8 libpci3 libpcre2-8-0 libpcre3 libpipeline1 libpixman-1-0
libpng16-16 libpopt0 libprotobuf-c1 libpsl5 libpulse0 libpython2-dev libpython2-stdlib libpython2.7 libpython2.7-dev
libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libqrencode4 libquadmath0 librabbitmq4 librados2
libradosstriper1 librbd1 librdkafka1 librdmacm1 librgw2 librrd8 librrds-perl librtmp1 libsasl2-2 libsasl2-modules-db
libsdl1.2debian libseccomp2 libselinux1 libsemanage-common libsemanage1 libsepol1 libslang2 libsmartcols1
libsmbclient libsnappy1v5 libsndfile1 libspice-server1 libsqlite3-0 libss2 libssh2-1 libssl-dev libssl1.1
libstatgrab10 libstdc++6 libsystemd0 libtalloc2 libtasn1-6 libtcmalloc-minimal4 libtdb1 libtemplate-perl
libterm-readline-gnu-perl libtevent0 libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libthai-data
libthai0 libtimedate-perl libtinfo6 libtirpc-common libtirpc3 libtsan0 libtypes-serialiser-perl libu2f-server0
libubsan1 libuchardet0 libudev1 libunistring2 libunwind8 liburcu6 liburi-perl libusb-1.0-0 libusbredirparser1
libuuid-perl libuuid1 libvorbis0a libvorbisenc2 libwbclient0 libwrap0 libwww-perl libx11-6 libx11-data libx11-xcb1
libxau6 libxcb-render0 libxcb-shm0 libxcb1 libxext6 libxi6 libxml-libxml-perl libxml-namespacesupport-perl
libxml-parser-perl libxml-sax-base-perl libxml-sax-perl libxml-twig-perl libxml2 libxslt1.1 libxtables12 libyaml-0-2
libyaml-libyaml-perl libzstd1 linux-libc-dev locales login logrotate lsb-base lsof lvm2 lxcfs lynx lynx-common lzop
make man-db manpages mawk memtest86+ mime-support monitoring-plugins-basic monitoring-plugins-common mount
nagios-nrpe-server nano ncurses-base ncurses-bin ncurses-term netbase netcat-traditional netfilter-persistent
nfs-common nmap nmap-common numactl nvme-cli open-iscsi openssh-client openssh-server openssh-sftp-server openssl
parted passwd patch pciutils perl perl-base perl-openssl-defaults pinentry-curses postfix procps psmisc
python-apt-common python-markupsafe python-pastedeploy-tpl python-pip-whl python-pkg-resources python-six python2
python2-dev python2-minimal python2.7 python2.7-dev python2.7-minimal python3 python3-apt python3-asn1crypto
python3-bcrypt python3-bs4 python3-ceph-argparse python3-ceph-common python3-cephfs python3-certifi
python3-cffi-backend python3-chardet python3-cherrypy3 python3-cryptography python3-dateutil python3-debconf
python3-debian python3-debianbts python3-distutils python3-html5lib python3-httplib2 python3-idna python3-jwt
python3-lib2to3 python3-logutils python3-lxml python3-mako python3-markupsafe python3-minimal python3-openssl
python3-paste python3-pastedeploy python3-pastescript python3-pecan python3-pkg-resources python3-prettytable
python3-pycurl python3-pyinotify python3-pysimplesoap python3-rados python3-rbd python3-reportbug python3-repoze.lru
python3-requests python3-rgw python3-routes python3-setuptools python3-simplegeneric python3-simplejson
python3-singledispatch python3-six python3-soupsieve python3-tempita python3-urllib3 python3-virtualenv
python3-waitress python3-webencodings python3-webob python3-webtest python3-werkzeug python3-yaml qrencode
readline-common reportbug rpcbind rrdcached rsync rsyslog samba-common samba-libs sensible-utils smbclient socat
sqlite3 ssh ssl-cert strace sudo systemd systemd-sysv sysvinit-utils tar tasksel tasksel-data tcpdump telnet
thin-provisioning-tools time traceroute tzdata ucf udev uidmap update-inetd usb.ids usbutils util-linux vim-common
vim-tiny virtualenv wamerican wget whiptail wipe x11-common xfsprogs xinetd xkb-data xsltproc xxd xz-utils zlib1g
zstd
616 upgraded, 105 newly installed, 66 to remove and 0 not upgraded.
Need to get 66.5 MB/381 MB of archives.
After this operation, 243 MB of additional disk space will be used.
Do you want to continue? [Y/n]
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,204
1,513
164
South Tyrol/Italy
shop.proxmox.com
Hit:1 http://security.debian.org bullseye-security InRelease
Hit:2 http://ftp.debian.org/debian bullseye InRelease
Get:3 http://ftp.debian.org/debian bullseye-updates InRelease [39.4 kB]
Hit:4 http://download.proxmox.com/debian/ceph-octopus bullseye InRelease
There's no PVE repository, the ceph one only provides ceph and the rest are the base Debian ones:

Add the enterprise one, if this is a host with a valid subscription:
deb https://enterprise.proxmox.com/debian/pve bullseye pve-enterprise

Or else check the docs for available option:
https://pve.proxmox.com/wiki/Package_Repositories#sysadmin_enterprise_repo
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!