fsck exited with status code 12


New Member
Jul 1, 2023
I just moved and I tried booting up today and am getting a /dev/mapper/pve-root:**** Warning: Filesystem still has errors*****

fsck exited with status code 12

I tried running a manual fsck and get some other errors.

Searching around I didnt see this error code 12 much. Any way to fix this without reinstalling?

Or if this would need to be a reinstall could I pull the most recent backups from this initramfs console?

I also saw mention of loading a new install drive and attaching this one to see if there are missing files, would I just be able to copy over the pve-root directory?


  • Capture.PNG
    170.1 KB · Views: 11
  • Capture2.PNG
    45.1 KB · Views: 11


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!