Freenas?

Bobbbb

Well-Known Member
Jul 13, 2018
71
1
48
28
Hi!

I tried to install FreeNAS with passthough hard drives, and it was working fine...for a while.

now i get disk errors, and pool degraded messages.
I was advised i need to do a PCI passthough and not disk....but this complicates my life a bit.

i also saw someone mention i need to set the drive as writeback?

if someone can give me any tips, that will be highly appreciated .
 
so i tried pci passthrough....stupid question.....can i do pci passthough if my CPU doesn't support VT-d?

my XEON cpu has been stuck in customs for a few month now :-(
 
I did mine following this video in Youtube: Qumdkf3etGU
It's a disk passthrough and it's working fine. The only thing that doesn't work is SMART from inside FreeNAS, but you could do it from Proxmox.
My server has normal SATA controller, not RAID. This is very important!!!
What motherboard/server are you using and where are the HDD plug into?
 
I have an HP mictoserver GEN 8...
It is connected to a raid controller but it's not configured as raid
 
mmm there are a lot of info on the internet (FreeNAS, OpenZFS, etc) about not connecting to a RAID controller.
They say if you manage to get it to work in "IT" mode, sometimes requires a firmware upload, or maybe JBOD.
One thing you could try is to backup your FreeNAS config, boot with a USB stick (with FreeNAS) and restore the backup to see if you get the ZFS pool active and test if you get the same problems.
This way the FreeNAS would be running on bare-metal, but still using you RAID controller.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!