FreeNAS VM graceful shutdown

nosuch

New Member
Jul 5, 2019
15
1
3
41
I recently installed FreeNAS as a VM and it works fine along with PCIe passthrough of an HBA. However when I try to shut down the container it does not appear to be passing the command to FreeNAS. Do I need to install something like qemu-agent to make that work?

The other issue I have is that when I shutdown FreeNAS from within the web or console UI it reboots itself after. Anyone have a solution for this?
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
5,836
391
103
Hi,

if you have no qemu-guest-agent installed the VM gets an ACPI call to shutdown.
Ensure that the option "ACPI support" is activated or when you have activated the "QEMU Guest Agent" open that it is installed.
 

nosuch

New Member
Jul 5, 2019
15
1
3
41
Is there a qemu guest agent for FreeBSD? I realize I should do the same on my pfSense VM as it will likely have the same issue. Otherwise is the ACPI option you're referring to an option on the host somewhere or on the guest OS (FreeNAS)?
 

nosuch

New Member
Jul 5, 2019
15
1
3
41
Thanks, I'll watch for FreeNAS 12. Is the ACPI option something I need to enable in ProxMox, FreeNAS or both?
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
5,836
391
103
ACPI is default enabled.
PFSense is listening to ACPI call and shutdown.
I don't know what FreeNAS does.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!