Frage: sollten 7.4 backups auf 8.0 funktionieren?

gueniepr

Member
Nov 23, 2021
39
0
11
73
Ich hatte meine 3 VM's brav gesichert und dann eine 8.0 NEU Installation gemacht, weil ich eine ZFS Installation wollte. Ich habe dann das alte Dateisystem wieder hergestellt (ZFS Platten) dann habe ich die gesicherten VM eingespielt.

Leider wurden die nicht mehr richtig zurückgespielt ? Sie konnten zwar gestartet werde und funktionieren soweit. ABER

warum wurden die Daten aus der config nicht richtig benutzt?

Ich hatte z.B. auf vmdata (pool?) meine Datenpartitionen ~350GB auf vmhost (SSD pool) meine Betriebssysteme und auf der Proxmox Festplatte die EFI / TMP mini Partitionen. In der Config stand alles richtig zu lesen, aber gemacht hat das Teil was anderes!!

Unter 7.4 hat die Wiederherstellung super geklappt, wenn ich wieder mal einen "Bock" geschossen hatte ;-)

Funktioniert das unter der 8.0 noch nicht, oder habe ich Fehler gemacht?

Danke für eine Antwort
 
Hi,
was genau hat denn nicht geklappt beim wiederherstellen? Welche config wurde nicht richtig wiederhergestellt?
 
Hallo,

zum Beispiel ich habe eine Nextcloud VM gesichert da waren die Dateien so eingestellt

bios: ovmfboot: order=scsi0;ide2;net0cores: 10cpu: hostefidisk0: local-lvm:vm-205-disk-0,efitype=4m,pre-enrolled-keys=1,size=4Mhostpci0: 0000:81:10.4,pcie=1hostpci1: 0000:81:10.5,pcie=1ide2: none,media=cdrommachine: q35memory: 20480meta: creation-qemu=7.2.0,ctime=1680697856name: cloudnet0: virtio=4A:63:98:0D:F6:F8,bridge=vmbr0,firewall=1numa: 1onboot: 1ostype: l26scsi0: vmhost:vm-205-disk-0,cache=writeback,iothread=1,size=70Gscsi1: vmdata:vm-205-disk-0,cache=writeback,iothread=1,size=300Gscsihw: virtio-scsi-singlesmbios1: uuid=db300930-9943-493f-8014-0588dfc1ba8bsockets: 1tpmstate0: local-lvm:vm-205-disk-1,size=4M,version=v2.0vmgenid: 28457e9c-3d77-4172-a6ee-5d33a3270e65#qmdump#map:efidisk0:drive-efidisk0:local-lvm:raw:#qmdump#map:scsi0:drive-scsi0:vmhost:raw:#qmdump#map:scsi1:drive-scsi1:vmdata:raw:#qmdump#map:tpmstate0:drive-tpmstate0-backup:local-lvm:raw:

ist schlecht zu lesern :-(, aber auf jeden Fall wurden alles auf ein "Pool" geschrieben, da man einen Ort angeben MUSS, beim einspielen und dadurch anscheinend die Config egal ist?
 
Hallo,

zum Beispiel ich habe eine Nextcloud VM gesichert da waren die Dateien so eingestellt

bios: ovmfboot: order=scsi0;ide2;net0cores: 10cpu: hostefidisk0: local-lvm:vm-205-disk-0,efitype=4m,pre-enrolled-keys=1,size=4Mhostpci0: 0000:81:10.4,pcie=1hostpci1: 0000:81:10.5,pcie=1ide2: none,media=cdrommachine: q35memory: 20480meta: creation-qemu=7.2.0,ctime=1680697856name: cloudnet0: virtio=4A:63:98:0D:F6:F8,bridge=vmbr0,firewall=1numa: 1onboot: 1ostype: l26scsi0: vmhost:vm-205-disk-0,cache=writeback,iothread=1,size=70Gscsi1: vmdata:vm-205-disk-0,cache=writeback,iothread=1,size=300Gscsihw: virtio-scsi-singlesmbios1: uuid=db300930-9943-493f-8014-0588dfc1ba8bsockets: 1tpmstate0: local-lvm:vm-205-disk-1,size=4M,version=v2.0vmgenid: 28457e9c-3d77-4172-a6ee-5d33a3270e65#qmdump#map:efidisk0:drive-efidisk0:local-lvm:raw:#qmdump#map:scsi0:drive-scsi0:vmhost:raw:#qmdump#map:scsi1:drive-scsi1:vmdata:raw:#qmdump#map:tpmstate0:drive-tpmstate0-backup:local-lvm:raw:

ist schlecht zu lesern :-(, aber auf jeden Fall wurden alles auf ein "Pool" geschrieben, da man einen Ort angeben MUSS, beim einspielen und dadurch anscheinend die Config egal ist?
Beim restore muss nicht zwingend ein storage angegeben werde, default ist restore der disks via config storage. Dazu müssen die storages aber existieren.
 
Die hatte ich extra wieder angelegt, weil ich nicht wusste ob die auch angelegt werden, damit das ganze auch funktioniert ? Aber anscheinend wie ich mich erinnere, musste ich ein storage angeben ? Aber ich kann es mit dieser vm ja noch mal probieren ob es auch ohne geht ?
 
Habs bei mir lokal gerade eben nochmals schnell getestet. 2 disks auf 2 verschiedenen storages aus einem PVE 7.4 Backup nach PBS werden nach dem upgrade auf PVE 8.0 beim restore ohne Angabe einer target storage wie gewünscht auf die entsprechenden storages geschrieben.
 
Es geht nicht ohne eine storage anzugeben man kommt nicht weiter wenn keine angegeben ist, das dürfte dann wohl ein Fehler sein oder ??

PS: ich stolpere immer über sowas ;-)
 
Es geht nicht ohne eine storage anzugeben man kommt nicht weiter wenn keine angegeben ist, das dürfte dann wohl ein Fehler sein oder ??

PS: ich stolpere immer über sowas ;-)
Wie gesagt, kann das hier so nicht nachstellen. Ist sichergestellt das die storages exakt gleich wie vor dem neu installieren eingerichtet wurden?
 
So viel ich weiß ja, da ich aber ein Anfänger bei Proxmox bin, könnte etwas schief gelaufen sein ? Ich habe einfach die Platten gelöscht (gewaipt) und dann wieder ein ZFS mirror erstellt, unter den selben Namen wie vorher ? Mir werden auch alle angezeigt, nur bei mir muss ich eine auswählen da ich sonst nicht weiter komme?
 
So viel ich weiß ja, da ich aber ein Anfänger bei Proxmox bin, könnte etwas schief gelaufen sein ? Ich habe einfach die Platten gelöscht (gewaipt) und dann wieder ein ZFS mirror erstellt, unter den selben Namen wie vorher ? Mir werden auch alle angezeigt, nur bei mir muss ich eine auswählen da ich sonst nicht weiter komme?
Ja, falls die Name der storages nicht mit denen zusammenpassen welche in der config stehen MUSS man eine target storage angeben, ansonsten wird die Option gegeben diese aus der config zu nehmen.
 
Andere Frage dazu, beim nächsten Update, kann man eigentlich konfigurierte storage mit ZFS wieder importieren. Sonst habe das selbe Problem beim nächsten update, jetzt behelfe ich mich mit der installation auf die proxmox platte und verschiebe nachher das Filesystem. dann hoffe ich falls etwas passiert diese Backups dann wieder "EINFACH" zu installieren ;-)
 
Andere Frage dazu, beim nächsten Update, kann man eigentlich konfigurierte storage mit ZFS wieder importieren. Sonst habe das selbe Problem beim nächsten update, jetzt behelfe ich mich mit der installation auf die proxmox platte und verschiebe nachher das Filesystem. dann hoffe ich falls etwas passiert diese Backups dann wieder "EINFACH" zu installieren ;-)
Eine Neuinstallation ist nicht notwendig. Wieso nicht einfach ein in-place upgrade machen?
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!