Forward and Reverse Lookup different - blocked

seteq

Member
Dec 15, 2015
18
3
23
37
Hi,

The inbound emails of one company are getting blocked, because they seem to have somd kind of uncommon DNS setup.
The reverse lookup of the server on the inbound connection is set correctly, but the A-Record of the used hostname points to another server.

Reverse lookup:
Code:
# host 1.2.3.4
4.3.2.1.in-addr.arpa domain name pointer mail.othercorp.com.

Forward lookup:
Code:
# host mail.othercorp.com
mail.othercorp.com has address 5.6.7.8.

Log from message tracking center:
Code:
May 16 15:08:26 mx1 postfix/smtpd[30202]: warning: hostname mail.othercorp.com does not resolve to address 1.2.3.4
May 16 15:08:26 mx1 postfix/smtpd[30202]: connect from unknown[1.2.3.4]
May 16 15:08:28 mx1 postfix/smtpd[30202]: NOQUEUE: reject: RCPT from unknown[1.2.3.4]: 450 4.7.25 Client host rejected: cannot find your hostname, [1.2.3.4]; from=<sender@othercorp.com> to=<validrecipient@mycorp.com> proto=ESMTP helo=<mail.othercorp.com>
May 16 15:08:34 mx1 postfix/smtpd[30202]: disconnect from unknown[1.2.3.4] ehlo=2 starttls=1 mail=1 rcpt=0/3 rset=1 quit=1 commands=6/9

What can I do to allow this server to connect?

Thanks
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
6,829
1,031
164
* It should be enough to add it it to the Mail Proxy Whitelist (GUI->Configuration->Mail Proxy->Whitelist)
* If not you might need to disable the 'reject unknown clients' option in GUI->Configuration->Mail Proxy->Options

I hope this helps!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!