flatcar and rootless podman destroying my vm

Nimo

Active Member
Dec 2, 2021
32
1
28
Hi,
i am trying to get a flatcar vm with rootless podman working. it actually works a while with containers haproxy, whoami, socket-proxy and arcane running. But unfortunately after 3, 4, 5 or several more reboots something, somehow destroys the vm and after reboot no container is able to start anymore. I somehow got a feeling that the arcane container might trigger this issue, but i am not sure. Podman gives errors that it can not open /etc/sub[ug]id anymore and other failures, but sub[ug]id are set properly and output before is [{0 1000 1} {1 100000 65536}] [{0 1000 1} {1 100000 65536}].
Code:
podman system migrate
podman info --format '{{.Host.IDMappings}}'
ERRO[0000] cannot find UID/GID for user myuser: cannot read subids - check rootless mode in man pages.
WARN[0000] Using rootless single mapping into the namespace. This might break some images. Check /etc/subuid and /etc/subgid for adding sub*ids if not using a network user
{[{0 1000 1}] [{0 1000 1}]}
i also noticed that this error msg will show up in dmesg after the vm got corrupted
Code:
               device-mapper: verity: sha256 using shash "sha256-ni"
[    4.567312] device-mapper: verity: Unrecognized verity feature request: root_hash_sig_key_desc
[    4.568903] device-mapper: table: 254:1: verity: Unrecognized verity feature request (-EINVAL)
[    4.570306] device-mapper: ioctl: error adding target to table
tbh, i have absolutely no clue where this comes from and AI doesnt know either. Strangely this also shows up on another vm with flatcar which is just running a single gitlab instance. Same issue there.
Maybe someone here can help?

edit: the culprit is not the arcane container. I thought it might be a problem with the bind mounted podman.sock. But turns out when not deploying arcane at all the issue still shows up.
 
Last edited: