festplatte mounten

nakooe89

New Member
Nov 23, 2019
8
0
1
30
moin bzw abend :) je nach dem wo ihr sitzt

ich möchtge gerne meinem Container die festplatte /dev/sdj/ vom hauptroot durchreichen.
habe die config geöffnet vom /etc/pve/lxc 103.,con und habe dort den eintrag

lxc.mount.entry = /dev/sdj /var/lib/lxc/103/rootfs/dev/sdj none bind 0 0
eingetragen.

dieser eintrag muss scheinbar falsch sein. nach dem ich per nano gespeichert habe schmierte mir der hauptroot ab :)

hat jemand einen korrigierten ? womit es läuft.

würde mich sehr freuen

weil das durchreichen durch eine vm ist viel schwieriger als durch einen container.


mit freundlichen grüßen

nakooe
 

bluesite

Member
Oct 18, 2017
28
1
8
44
also bei mir hab ich das so gemacht in meiner xxx.conf des Kontainers

also einfach als Zeile einfügen das von Dir ist glaub für eine älte Proxmox Version (Pfade natürlich anpassen auf Deine Bedürfnisse)

mp0: /home/share/data/,mp=/home/share/data

ich hab die aktuelle Version installiert

proxmox-ve: 6.0-2 (running kernel: 5.0.21-5-pve)
pve-manager: 6.0-15 (running version: 6.0-15/52b91481)
 

nakooe89

New Member
Nov 23, 2019
8
0
1
30
ich ceck das noch nicht ganz was du mir das gepostet hast
PS: habe auch die aktuelle installiert.


für was steht das mp0 ?
und für was ist ,mp ?

ich möchte ja mehrere festplatten einbinden wo bekomme dann die bezeichnungen dann her von mein festplatten für mp0 ?

oder habe ich mit dem befehl alle festplatten auf einmal drin ?

mp0: /home/share/data/,mp=/home/share/data
 

LnxBil

Famous Member
Feb 21, 2015
4,434
442
103
Germany
lxc.mount.entry = /dev/sdj /var/lib/lxc/103/rootfs/dev/sdj none bind 0 0
Das kann nicht funktionieren, da bind dafür da ist Verzeichnisse zu mounten, du willst aber eine Festplatte/Blockgerät mounten. Das muss man zuerst im Host mounten dann wie @bluesite geschrieben hat mit einem Bind-Mount (über mp) dort einhängen. Ich hoffe das ist etwas Hintergrund um zu beleuchten was da nicht funktioniert hat.
 

nakooe89

New Member
Nov 23, 2019
8
0
1
30
so leute irgendwas mache ich falsch. wenn ich den befehl hinzfüge in die conf startet der container nicht mehr.

mp0: /mnt/platte9/,mp=/home/platte9
also hauptroot liegt die festplatte platte9 auf /mnt/platte9
und auf dem container habe ich einen ordner /home/platte9

habe ich einen denkfehler ?

mfg nakooe
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!