Failed to restart pveproxy.service: Unit pveproxy.service is masked.

Ernesto Garcia

New Member
Jan 29, 2018
I have issue with the updating my proxmox v4.4, I cant acces in to the web. I read so many forums and any help me because that open this new one. Someone can help me. is life or death xD.

systemctl status pveproxy
● pveproxy.service
Loaded: masked (/dev/null)
Active: inactive (dead)

systemctl restart pveproxy
Failed to restart pveproxy.service: Unit pveproxy.service is masked.

pveversion -v
-bash: pveversion: command not found
apt-get install proxmox-ve
apt-get install proxmox-ve
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
proxmox-ve : Depends: pve-manager but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
have you configured the repositories correctly? did you do an apt-get update before?
Yes I did befor update but that update make this error, I can ckeck the repositories, can you give me the link.
Proxmox server send me email. and change the repositories also the repositories may updagrade the system to last version, I have access web now but the VM show stop but its running.

apt (1.4.2) unstable; urgency=medium

If periodic updates and unattended upgrades are enabled, the start of
periodic updates are now distributed over 24 hour intervals (as in 1.2
to 1.4), whereas starting unattended-upgrade has been restricted to a
time between 6 and 7 am. This only affects systems using systemd, other
systems still use the classical hourly cron job.

-- Julian Andres Klode <> Thu, 04 May 2017 22:54:02 +0200

apt (1.4~beta1) unstable; urgency=medium

Support for GPG signatures using the SHA1 or RIPE-MD/160 hash
algorithms has been disabled. Repositories using Release files
signed in such a way will stop working. This change has been made
due to security considerations, especially with regards to possible
further breakthroughs in SHA1 breaking during the lifetime
of this APT release series.

It is possible (but STRONGLY ADVISED AGAINST) to revert to the previous
behaviour by setting the options
APT::Hashes::SHA1::Weak "yes";
APT::Hashes::RIPE-MD/160::Weak "yes";
Note that setting these options only affects the verification of the overall
repository signature.

-- Julian Andres Klode <> Fri, 25 Nov 2016 13:19:32 +0100

apt (1.2~exp1) experimental; urgency=medium

[ Automatic removal of debs after install ]
After packages are successfully installed by apt(8),
the corresponding .deb package files will be
removed from the /var/cache/apt/archives cache directory.

This can be changed by setting the apt configuration option
"Binary::apt::APT::Keep-Downloaded-Packages" to "true". E.g:

# echo 'Binary::apt::APT::Keep-Downloaded-Packages "true";' \
> /etc/apt/apt.conf.d/01keep-debs

Please note that the behavior of apt-get is unchanged. The
downloaded debs will be kept in the cache directory after they
are installed. To enable the behavior for other tools, you can set
"APT::Keep-Downloaded-Packages" to false.

[ Compressed indices ]
If you use Acquire::gzipIndexes, or any other compressed index targets,
those will now be compressed with the fastest supported algorithm,
currently lz4.

-- Michael Vogt <> Tue, 05 Jan 2016 19:22:16 +0100

apt (1.1~exp9) experimental; urgency=medium

A new algorithm for pinning has been implemented, it now assigns a
pin priority to a version instead of assigning a pin to a package.

This might break existing corner cases of pinning, if they use multiple
pins involving the same package name or patterns matching the same
package name, but should overall lead to pinning that actually works
as intended and documented.

-- Julian Andres Klode <> Mon, 17 Aug 2015 14:45:17 +0200

glibc (2.21-2) unstable; urgency=medium

Starting with version 2.21-1, the glibc requires a 3.2 or later Linux
kernel. If you use an older kernel, please upgrade it *before*
installing this glibc version. Failing to do so will end-up with the
following failure:

Preparing to unpack .../libc6_2.21-1_amd64.deb ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
3.2 or later. Please upgrade your kernel before installing

Note: This obviously does not apply to non-Linux kernels.

-- Aurelien Jarno <> Thu, 03 Dec 2015 22:46:21 +0100


  • Captura.PNG
    23.5 KB · Views: 53


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!