Failed to import pool 'rpool'

Davekromo

New Member
Oct 22, 2019
2
0
1
32
Hello,

I recently faced a power outage with my server and upon booting it back up, it's showing the error message stating 'failed to import pool 'rpool''. The server still does detect all my drives and running zpool import does show all my pools of storage including 'rpool. I've only tried editing the file /etc/default/zfs so that ZFS_INITRD_PRE_MOUNTROOT_SLEEP and ZFS_INITRD_PRE_MODPROBE_SLEEP to 10(no commands were done after editting the file) as I found a few suggestions online for this. Running the command displayed in the error message doesn't work, running the command works but upon reboot the server displays the same error. I'm at a loss on what to do now.

Dave
 
Update!

I fixed the issue, turns out because I added 3 Sata drives in total, likely have to do with the mention of "Boot fails and goes into busybox" ... "is because zfs is invoked too soon", as per the below document. I edited 'ZFS_INITRD_PRE_MOUNTROOT_SLEEP='0'' to ZFS_INITRD_PRE_MOUNTROOT_SLEEP='10'' just to be on the safe side and it reboots with no issues now.

https://pve.proxmox.com/wiki/ZFS:_Tips_and_Tricks
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!