Hi!
Im trying to configure EVPN-VXLAN on proxmox 8.1.4. I have a spine and few leaves in my "DC" so it time to add proxmox to farbic.
Im going to SDN settings and configure spet-by-step...
SND-Option:
BGP controller: node3, asn 64803(local asn for NODE), peers 172.18.2.222(SPINE ip, and we dont define spine asn because its external), ebgp - yes, loopback 10.131.0.103, ebgp-multihop 10.
EVPN controller: asn 64601(spine asn), peers 10.132.255.251(spine ip)
Then i make EVPN ZONE with (l3vni) and VNET with (l2vni). Then i hit apply button and going to look at frr config and sdn-interface config:
And the problem is: proxmox looking into peers(172.18.2.222) and search local ip from this netwok(it is 172.18.2.103) and then place it into config as: router-id, network for announce, src in route-map, source of vxlan interfaces. This is wrong, there MUST be a LOOPBACK IP to act as source of vtep and all other, not a random link address.
Who has encountered this and how to work with it?
and SDN:
Im trying to configure EVPN-VXLAN on proxmox 8.1.4. I have a spine and few leaves in my "DC" so it time to add proxmox to farbic.
Im going to SDN settings and configure spet-by-step...
SND-Option:
BGP controller: node3, asn 64803(local asn for NODE), peers 172.18.2.222(SPINE ip, and we dont define spine asn because its external), ebgp - yes, loopback 10.131.0.103, ebgp-multihop 10.
EVPN controller: asn 64601(spine asn), peers 10.132.255.251(spine ip)
Then i make EVPN ZONE with (l3vni) and VNET with (l2vni). Then i hit apply button and going to look at frr config and sdn-interface config:
And the problem is: proxmox looking into peers(172.18.2.222) and search local ip from this netwok(it is 172.18.2.103) and then place it into config as: router-id, network for announce, src in route-map, source of vxlan interfaces. This is wrong, there MUST be a LOOPBACK IP to act as source of vtep and all other, not a random link address.
Who has encountered this and how to work with it?
Bash:
router bgp 64803
bgp router-id 172.18.2.103(dont care, but better ist be 10.131.0.103)
no bgp default ipv4-unicast
bgp disable-ebgp-connected-route-check
coalesce-time 1000
neighbor BGP peer-group
neighbor BGP remote-as external
neighbor BGP bfd
neighbor BGP ebgp-multihop 10
neighbor VTEP peer-group
neighbor VTEP remote-as external
neighbor VTEP bfd
neighbor VTEP ebgp-multihop 10
neighbor VTEP update-source 10.131.0.103(thats correct)
neighbor 172.18.2.222 peer-group BGP
neighbor 10.132.255.251 peer-group VTEP
!
address-family ipv4 unicast
network 172.18.2.103/32(wrong, must be 10.131.0.103/32)
neighbor BGP activate
neighbor BGP soft-reconfiguration inbound
exit-address-family
!
address-family l2vpn evpn
neighbor VTEP activate
neighbor VTEP route-map MAP_VTEP_IN in
neighbor VTEP route-map MAP_VTEP_OUT out
advertise-all-vni
autort as 64601
exit-address-family
exit
!
router bgp 64803 vrf vrf_therecom
bgp router-id 172.18.1.103(wrong, must be 10.131.0.103)
no bgp hard-administrative-reset
no bgp graceful-restart notification
!
address-family l2vpn evpn
route-target import 64601:30501
route-target export 64601:30501
exit-address-family
exit
!
ip prefix-list loopbacks_ips seq 10 permit 0.0.0.0/0 le 32
!
route-map MAP_VTEP_IN permit 1
exit
!
route-map MAP_VTEP_OUT permit 1
exit
!
route-map correct_src permit 1
match ip address prefix-list loopbacks_ips
set src 172.18.2.103(wrong, must be 10.131.0.103)
exit
and SDN:
Code:
auto vrfvx_123
iface vrfvx_123
vxlan-id 30501
vxlan-local-tunnelip 172.18.1.103(wrong, must be 10.131.0.103)
bridge-learning off
bridge-arp-nd-suppress on
mtu 1700
auto vxlan_evpn1
iface vxlan_evpn1
vxlan-id 20501
vxlan-local-tunnelip 172.18.1.103(wrong, must be 10.131.0.103)
bridge-learning off
bridge-arp-nd-suppress on
mtu 1700