eveng - neither intel vt-x or amd-v found

korpaczov

New Member
Oct 27, 2023
7
2
3
Hey everyone,
I'm getting a common error message for which there are numerous troubleshooting guides available. I tried researching various forums and watching multiple YouTube videos, I'm still struggling with the issue.
Here's the scenario: I've set up Proxmox on my old laptop and installed EVE-NG on a virtual machine. However, upon starting the VM, I'm prompted with an error stating "neither Intel VT-x nor AMD-V found."
To resolve this, I accessed the BIOS and adjusted settings, hoping to boot into Windows from another hard drive. I changes an order of hard drives a few times but it always boots to proxmox. It seems like Windows is gone, and I'm unable to eliminate this error.
I am still a newbie to Proxmox, I apologize if my question seems basic. I'm running out of ideas on how to troubleshoot this problem and would greatly appreciate any guidance.
 
To run VMs at near to normal speeds, you need a CPU with virtualization acceleration enabled, which most CPUs can. This is called Intel VT-x or AMD-V (depending on which platform you use). If you enable this in the motherboard BIOS, your VMs will run fine.
If you installed Proxmox on your only drive in the laptop, then the installer has wiped that drive and removed Windows. If you have multiple drives and you installed Proxmox on a different drive than Windows, you should be able to boot back into Windows. But I don't know your BIOS and if you selected the right drive (during installation of Proxmox or in the BIOS), sorry.
Can you boot an USB drive with GParted Live (or something like it) and inspect your drives to see which operating system is installed where?
 
To run VMs at near to normal speeds, you need a CPU with virtualization acceleration enabled, which most CPUs can. This is called Intel VT-x or AMD-V (depending on which platform you use). If you enable this in the motherboard BIOS, your VMs will run fine.
If you installed Proxmox on your only drive in the laptop, then the installer has wiped that drive and removed Windows. If you have multiple drives and you installed Proxmox on a different drive than Windows, you should be able to boot back into Windows. But I don't know your BIOS and if you selected the right drive (during installation of Proxmox or in the BIOS), sorry.
Can you boot an USB drive with GParted Live (or something like it) and inspect your drives to see which operating system is installed where?
Hello! thanks for a quick response. I've got two drives and I took a peek at the BIOS to make sure the laptop boots from one of them. Then I changed the boot order to the second drive, the laptop continues to boot into Proxmox all the time. It appears that I might have installed Proxmox on the same drive as Windows, and now windows is gone. Is there an alternative troubleshooting method available without access to the Windows environment?
 
Is there an alternative troubleshooting method available without access to the Windows environment?
Proxmox is also "just Linux". I already suggested GParted Live. I'm not sure what you are asking.
You should be able to enable virtualization acceleration (Intel VT-x or AMD-V) in your motherboard BIOS. Can you provide a link to the BIOS manual, so people can help you find the setting? Then you can just run VMs with Proxmox.
 
Proxmox is also "just Linux". I already suggested GParted Live. I'm not sure what you are asking.
You should be able to enable virtualization acceleration (Intel VT-x or AMD-V) in your motherboard BIOS. Can you provide a link to the BIOS manual, so people can help you find the setting? Then you can just run VMs with Proxmox.
Aspire E5-575
bios InsydeH20 v.1.47
 

Attachments

  • IMG_6858-min.jpeg
    IMG_6858-min.jpeg
    933.8 KB · Views: 11
  • IMG_6853-min.jpeg
    IMG_6853-min.jpeg
    796.8 KB · Views: 9
  • IMG_6854-min.jpeg
    IMG_6854-min.jpeg
    797.4 KB · Views: 9
  • IMG_6855-min.jpeg
    IMG_6855-min.jpeg
    893.7 KB · Views: 9
  • IMG_6856-min.jpeg
    IMG_6856-min.jpeg
    872.5 KB · Views: 9
Alright, I accessed the BIOS by holding the Tab and FN keys. Now, the Advanced Settings are accessible. Within the CPU settings, I found that the ''Intel (VMX) Virtualization Technology'' was already enabled.
 
  • Like
Reactions: leesteken
another setting that I found in system agent configuration is "VT-d'' which is also enabled. I am still getting an error ''neither Intel VT-x nor AMD-V found''
 
Alright, I accessed the BIOS by holding the Tab and FN keys. Now, the Advanced Settings are accessible. Within the CPU settings, I found that the ''Intel (VMX) Virtualization Technology'' was already enabled.
This looks like the correct setting. Maybe try setting it to Disabled, to see if the BIOS might be the wrong way round? I don't know anything about your system, sorry.
 
Yeah, I'm not giving up. It seems to be related to nested virtualization. Someone had exactly the same problem here: https://forum.proxmox.com/threads/eve-unetlab-on-proxmox.36486/ Since I'm encountering this error in the VM console, I have to turn on nested virtualization. It's already enabled on my host (physical hardware). I'm trying to follow the provided guide step by step, but I'm kind of stuck on setting a CPU type as host in my VM console. I enter the command 'qm set <vmid> --cpu host.' In my case, vmid is 102, and I'm getting an error 'qm: command not found. Also tried to run this command with sudo but no luck
 
Last edited:
  • Like
Reactions: orinoco
Yeah, I'm not giving up. It seems to be related to nested virtualization. Someone had exactly the same problem here: https://forum.proxmox.com/threads/eve-unetlab-on-proxmox.36486/ Since I'm encountering this error in the VM console, I have to turn on nested virtualization.
I did not realize. That is indeed a different issue.
It's already enabled on my host (physical hardware). I'm trying to follow the provided guide step by step, but I'm kind of stuck on setting a CPU type as host in my VM console. I enter the command 'qm set <vmid> --cpu host.' In my case, vmid is 102, and I'm getting an error 'qm: command not found. Also tried to run this command with sudo but no luck
That's just setting the CPU Type to Host, which you can easily do via the Proxmox web GUI. Alternatively, make sure you are running qm as user root.
You might need to enable nested virtualization in Proxmox: https://pve.proxmox.com/wiki/Nested_Virtualization
 
  • Like
Reactions: rudydevolder
Yeah I changed it to ''host'' in the hardware tab and now the error is gone. Eveng still not working as expected tho. I added a mikrotik router to my lab but it is not powering up. I did some research and it seems that eveng does not work well with a new proxmox kernel. It used to be working fine with proxmox 6.x
 
Guys, remember that Eve-NG uses Quemu so virtualized over a Virtualized environment the only way to eliminate the " WARNING: neither Intel VT-x or AMD-V found " , very easy.

1. Turn off the VM XXX
2. Select the VM XXX
3. Click on Hardware
4. Click on Procesors
5. On Type section find the word host at the end of the list
6. Click Host
7. Click OK
8. turn the VM XXX ON and the message disappears.

Reference Link: https://www.youtube.com/watch?v=n9ctGa7U3hE
 
Confirmed!
Setting processor type to Host cleared up the error in EVE on a VM on a Dell R730. I'll certainly remember that for upcoming nested VM experiments.
Thanks!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!