Error with pve-headers

oX9ke

New Member
May 15, 2019
10
1
1
48
Using Proxmox 5.4.6. I have installed pve-headers package but whenever I try to install something that requires it (wireguard) I'm getting the following error:

Code:
Error! Your kernel headers for kernel 4.15.18-14-pve cannot be found.
Please install the linux-headers-4.15.18-14-pve package,
or use the --kernelsourcedir option to tell DKMS where it's located

Here is what I get when I try to install pve-headers:

Code:
root@proxmox:~# apt install pve-headers
Reading package lists... Done
Building dependency tree       
Reading state information... Done
pve-headers is already the newest version (5.4-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I've rebooted twice now after installing pve-headers but still have the same issue.
 
Looks like i had to do
Code:
apt install pve-headers-4.15.18-14-pve
for some reason. Not sure why it didn't pick up the headers that i needed on its own.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!