error during cfs-locked rbd: error opening image


Aug 30, 2019
I would like to delete disk from VM but when I click remove from GUI i get:
error during cfs-locked 'storage-HDD' operation: rbd error: rbd: error opening image vm-001-disk-0: (2) No such file or directory

When I type command:
 rbd ls -l HDD

Then I don't see such disk. Look like it doesn't exist.
How could I delete this one with safe way from my VM?
  • Like
Reactions: proximoxi2
I get the same error when I try to delete a container:
TASK ERROR: rbd error: rbd: error opening image vm-113-disk-1: (2) No such file or directory
Have you found a solution how to delete the container/VM anyway?
Workaround was move vm to another node or change some value in "option" for example protected mode.
After update Proxmox to 6.4-9 I do not notice such problem .
Hm ok, I moved the container to a new node and changed some option, but still get the same error when I try to remove the container :(
one of the following should work around the issue:
  • edit the configuration file /etc/pve/lxc/<ID>.conf and remove the line with the disk.
  • allocate a new volume where it's missing pvesm alloc <storeid> 113 vm-113-disk-1 1G.
  • Like
Reactions: proximoxi2


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!