Error cfs-lock 'storage-NAS

cdsJerry

Renowned Member
Sep 12, 2011
207
8
83
I have two Proxmox servers running currently. One is 8.03 and the other is 7.3-4 Eventually everything will be on the new server but I don't have all the vms moved yet.
I see my backups are failing with an error
trying to acquire cfs lock 'storage-NAS3' ...
trying to acquire cfs lock 'storage-NAS3' ...
trying to acquire cfs lock 'storage-NAS3' ...
TASK ERROR: cfs-lock 'storage-NAS3' error: got lock request timeout

And another one failing with error
TASK ERROR: 'storage-NAS3'-locked command timed out - aborting

These were both on the 8.0.3 version.

The version 7 server used to work fine but now it's also throwing errors
INFO: starting new backup job: vzdump 104 105 --compress lzo --quiet 1 --storage ProxNas3 --mailnotification failure --mode snapshot
INFO: Starting Backup of VM 104 (qemu)
INFO: Backup started at 2023-08-07 17:15:27
INFO: status = running
INFO: VM Name: Mail-Server1-7-23
INFO: include disk 'virtio0' 'local-lvm:vm-104-disk-0' 700G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating vzdump archive '/mnt/pve/ProxNas3/dump/vzdump-qemu-104-2023_08_07-17_15_10.vma.lzo'
INFO: issuing guest-agent 'fs-freeze' command
INFO: issuing guest-agent 'fs-thaw' command
INFO: started backup task 'de33172b-a942-4fb9-8e45-64efa3830cd3'
INFO: resuming VM again
INFO: 0% (1.0 GiB of 700.0 GiB) in 3s, read: 352.8 MiB/s, write: 296.6 MiB/s
lzop: No space left on device: <stdout>
INFO: 0% (1.4 GiB of 700.0 GiB) in 36s, read: 11.1 MiB/s, write: 11.1 MiB/s
ERROR: vma_queue_write: write error - Broken pipe

I even tried to manually go in and delete my backups but it won't let me do that either. I'm suddenly uncomfortable as I realize my backups aren't there. I see a lot of people seem to be having a similar problem but I don't see a solution in those threads. What do I need to do? Be specific as my Linux knowledge is limited and I'm sick on top of that so maybe not thinking as clearly as I'd like.
 
I rebooted the version 8 server yesterday. This morning it's not showing an error on either server (never touched the version 7 machine). It looks like all backups ran successfully last night. So I don't know what caused it, or what fixed it, but it's currently working.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!