Emulation of arm on amd64 host - error on boot

kellerfelix

Member
Jan 24, 2019
13
1
6
48
Hello everybody,

the new version apparently supports the emulation of poor versions of z. Debian or Ubuntu on amd64 hosts.

If that worked, that would be a great thing.
Unfortunately, I'm trying in vain to create an arm64 version of Debian or Ubuntu as a virtual machine.

I'm doing it as normal as I always do when creating VMs and then select the arm image. When the VM starts then, I get the following error message:

nothing to boot: no search file or directory (http://ipxe.org/2d03e13b)

I suspect that I still have to make any settings?
Can someone help me there?

Thank you in advance and greetings
Frank

here my configs:

PVE Version:
proxmox-ve: 5.3-1 (running kernel: 4.15.18-9-pve)
pve-manager: 5.3-5 (running version: 5.3-5/97ae681d)
pve-kernel-4.15: 5.2-12
pve-kernel-4.15.18-9-pve: 4.15.18-30
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-3
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-43
libpve-guest-common-perl: 2.0-18
libpve-http-server-perl: 2.0-11
libpve-storage-perl: 5.0-33
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.0.2+pve1-5
lxcfs: 3.0.2-2
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-22
pve-cluster: 5.0-31
pve-container: 2.0-31
pve-docs: 5.3-1
pve-edk2-firmware: 1.20181023-1
pve-firewall: 3.0-16
pve-firmware: 2.0-6
pve-ha-manager: 2.0-5
pve-i18n: 1.0-9
pve-libspice-server1: 0.14.1-1
pve-qemu-kvm: 2.12.1-1
pve-xtermjs: 1.0-5
qemu-server: 5.0-43
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.12-pve1~bpo1

VM:

bootdisk: scsi0
cores: 1
ide2: local:iso/ubuntu-18.04.1-server-arm64.iso,media=cdrom
memory: 512
name: test2
net0: virtio=82:2B:BF:64:C3:44,bridge=vmbr0
numa: 0
ostype: l26
scsi0: local-lvm:vm-104-disk-0,size=16G
scsihw: virtio-scsi-pci
smbios1: uuid=fbc28031-459a-49eb-9126-65af17fa956b
sockets: 1
vmgenid: c64902e3-352d-4dcb-ac24-78c7ae006672
 
you have to set the architecture:

qm set ID -arch aarch64
 
Hi Dominik,

thank you! I tryed that. But the vm want start after.

OutputStatus

Stop
qemu-system-aarch64: -device vmgenid,guid=1f8903c2-0eff-4529-8c56-8ae7cea1ddad: 'vmgenid' is not a valid device model name
TASK ERROR: start failed: command '/usr/bin/qemu-system-aarch64 -id 102 -name HomematicNUC -chardev 'socket,id=qmp,path=/var/run/qemu-server/102.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -chardev 'socket,id=qmp-event,path=/var/run/qmeventd.sock,reconnect=5' -mon 'chardev=qmp-event,mode=control' -pidfile /var/run/qemu-server/102.pid -daemonize -smbios 'type=1,uuid=1286540a-76a7-4064-af2a-d35d04094c46' -smp '1,sockets=1,cores=1,maxcpus=1' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash.jpg' -vnc unix:/var/run/qemu-server/102.vnc,x509,password -cpu cortex-a57 -m 1000 -device 'pci-bridge,id=pci.1,chassis_nr=1,bus=pcie.0,addr=0x1e' -device 'pci-bridge,id=pci.2,chassis_nr=2,bus=pcie.0,addr=0x1f' -device 'vmgenid,guid=1f8903c2-0eff-4529-8c56-8ae7cea1ddad' -device 'usb-ehci,id=ehci,bus=pcie.0,addr=0x1' -device 'usb-tablet,id=tablet,bus=ehci.0,port=1' -device 'usb-kbd,id=keyboard,bus=ehci.0,port=2' -device 'virtio-gpu,id=vga,bus=pcie.0,addr=0x2' -device 'virtio-balloon-pci,id=balloon0,bus=pcie.0,addr=0x3' -iscsi 'initiator-name=iqn.1993-08.org.debian:01:ae6f945db4e' -drive 'file=/var/lib/vz/template/iso/debian-9.7.0-arm64-netinst.iso,if=none,id=drive-ide2,media=cdrom,aio=threads' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -device 'virtio-scsi-pci,id=scsihw0,bus=pcie.0,addr=0x5' -drive 'file=/dev/pve/vm-102-disk-0,if=none,id=drive-scsi0,format=raw,cache=none,aio=native,detect-zeroes=on' -device 'scsi-hd,bus=scsihw0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0,id=scsi0,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap102i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown' -device 'virtio-net-pci,mac=3A:22:C3:93:13:FB,netdev=net0,bus=pcie.0,addr=0x12,id=net0,bootindex=300' -machine 'accel=tcg,type=virt'' failed: exit code 1

Any idea?
 
yes you have to also remove the 'vmgenid' line from the the config
 
Thanks!
One step further :)

But still get an error:

qemu-system-aarch64: -device ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200: Bus 'ide.1' not found
TASK ERROR: start failed: command '/usr/bin/qemu-system-aarch64 -id 102 -name HomematicNUC -chardev 'socket,id=qmp,path=/var/run/qemu-server/102.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -chardev 'socket,id=qmp-event,path=/var/run/qmeventd.sock,reconnect=5' -mon 'chardev=qmp-event,mode=control' -pidfile /var/run/qemu-server/102.pid -daemonize -smbios 'type=1,uuid=1286540a-76a7-4064-af2a-d35d04094c46' -smp '1,sockets=1,cores=1,maxcpus=1' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash.jpg' -vnc unix:/var/run/qemu-server/102.vnc,x509,password -cpu cortex-a57 -m 1000 -device 'pci-bridge,id=pci.1,chassis_nr=1,bus=pcie.0,addr=0x1e' -device 'pci-bridge,id=pci.2,chassis_nr=2,bus=pcie.0,addr=0x1f' -device 'usb-ehci,id=ehci,bus=pcie.0,addr=0x1' -device 'usb-tablet,id=tablet,bus=ehci.0,port=1' -device 'usb-kbd,id=keyboard,bus=ehci.0,port=2' -device 'virtio-gpu,id=vga,bus=pcie.0,addr=0x2' -device 'virtio-balloon-pci,id=balloon0,bus=pcie.0,addr=0x3' -iscsi 'initiator-name=iqn.1993-08.org.debian:01:ae6f945db4e' -drive 'file=/var/lib/vz/template/iso/debian-9.7.0-arm64-netinst.iso,if=none,id=drive-ide2,media=cdrom,aio=threads' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -device 'virtio-scsi-pci,id=scsihw0,bus=pcie.0,addr=0x5' -drive 'file=/dev/pve/vm-102-disk-0,if=none,id=drive-scsi0,format=raw,cache=none,aio=native,detect-zeroes=on' -device 'scsi-hd,bus=scsihw0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0,id=scsi0,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap102i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown' -device 'virtio-net-pci,mac=3A:22:C3:93:13:FB,netdev=net0,bus=pcie.0,addr=0x12,id=net0,bootindex=300' -machine 'accel=tcg,type=virt'' failed: exit code 1
 
Ok, found it myself.
I had to change the line in the conf vom ide2 to scsi1

Thanks, i test the emulation now.
Would be great if this works stable
 
For other users that maybe have same problems:
You also had to set in the conf a entry for bios:

bios: ovmf

and for graphics:

vga: serial0

I have still 1 problem: Cant use my keyboard correctly and so i cant go trough the installer. Can someone tell me how to set this?
 
Last edited:
Hello,

for weeks my vm with debian9 arm was working now. Yesterday i had to shutdown my vms and the proxmox host. After new boot i have now the problem that the vm with arm emulation of debian9 arm does Not boot. It goes directly to the grub installer the new install debian. I think from boot Order dvd where the iso file ist mounted. When I only let boot from hdd nothing Happens. I tryed to restore from several files but still same problem. All my other vms works fine. Can someone tell me what i can do to get it to Work? The hdd ist correct and still in scsi0. I dont Touched any settings.
Would be great If someone can help me.
Thanks
Frank
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!