[SOLVED] email blacklisted error!

tismo

New Member
Feb 20, 2023
13
1
3
Good day Everyone. I have been getting this error in the postfix syslog for the past 3 days and have been searching for the solution since.
Now, I have replaced that email address with my main email address from gmail because I thought maybe using duck.com is not accepted in PBS.I am still getting the error in the syslog.
I have put in my gmail email address in Configuration >> Other
I also made sure it was entered in Email section within the user option under Access Control>>>user management.
I also looked under /etc/postfix/main.cf but didnt see the duck.com email address.
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

myhostname=pbs.mydomain.com

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = $myhostname, localhost.$mydomain, localhost
relayhost =
mynetworks = 127.0.0.0/8
inet_interfaces = loopback-only
recipient_delimiter = +

compatibility_level = 2


Can anybody help me figure out where it could be still lingering in the config somewhere?
PBS info:
client version: 3.0.4


Code:
Oct 25 19:47:33 pbs postfix/qmgr[809]: 140B320761: from=<root@pbs.mydomain.com>, size=1036, nrcpt=1 (queue active)
Oct 25 19:47:33 pbs postfix/qmgr[809]: DBFF920816: from=<root@pbs.mydomain.com>, size=1036, nrcpt=1 (queue active)
Oct 25 19:47:33 pbs postfix/qmgr[809]: D5D7520760: from=<root@pbs.mydomain.com>, size=1036, nrcpt=1 (queue active)
Oct 25 19:47:33 pbs postfix/qmgr[809]: 4A579208E7: from=<root@pbs.mydomain.com>, size=1224, nrcpt=1 (queue active)
Oct 25 19:47:33 pbs postfix/qmgr[809]: 7A0AA20811: from=<root@pbs.mydomain.com>, size=1036, nrcpt=1 (queue active)
Oct 25 19:47:33 pbs postfix/smtp[2537]: 62EF3207F7: to=<someone@duck.com>, relay=smtp-inbound1.duck.com[52.146.152.212]:25, delay=213079, delays=213079/0.01/0.32/0, dsn=4.0.0, status=deferred (host smtp-inbound1.duck.com[52.146.152.212] refused to talk to me: 554 host [xx.xxx.xx.xxx] is blacklisted by zen.dnsbl)
Oct 25 19:47:33 pbs postfix/smtp[2541]: 4A579208E7: to=<someone@duck.com>, relay=smtp-inbound1.duck.com[52.146.152.212]:25, delay=157197, delays=157197/0.03/0.3/0, dsn=4.0.0, status=deferred (host smtp-inbound1.duck.com[52.146.152.212] refused to talk to me: 554 host [xx.xxx.xx.xxx] is blacklisted by zen.dnsbl)
Oct 25 19:47:33 pbs postfix/smtp[2538]: 140B320761: to=<someone@duck.com>, relay=smtp-inbound1.duck.com[52.146.152.212]:25, delay=213404, delays=213403/0.01/0.32/0, dsn=4.0.0, status=deferred (host smtp-inbound1.duck.com[52.146.152.212] refused to talk to me: 554 host [xx.xxx.xx.xxx] is blacklisted by zen.dnsbl)
Oct 25 19:47:33 pbs postfix/smtp[2540]: D5D7520760: to=<someone@duck.com>, relay=smtp-inbound1.duck.com[52.146.152.212]:25, delay=213298, delays=213297/0.03/0.31/0, dsn=4.0.0, status=deferred (host smtp-inbound1.duck.com[52.146.152.212] refused to talk to me: 554 host [xx.xxx.xx.xxx] is blacklisted by zen.dnsbl)
Oct 25 19:47:33 pbs postfix/smtp[2539]: DBFF920816: to=<someone@duck.com>, relay=smtp-inbound1.duck.com[52.146.152.212]:25, delay=211579, delays=211579/0.02/0.32/0, dsn=4.0.0, status=deferred (host smtp-inbound1.duck.com[52.146.152.212] refused to talk to me: 554 host [xx.xxx.xx.xxx] is blacklisted by zen.dnsbl)
Oct 25 19:47:33 pbs postfix/error[2546]: 7A0AA20811: to=<someone@duck.com>, relay=none, delay=212795, delays=212795/0.36/0/0, dsn=4.0.0, status=deferred (delivery temporarily suspended: host smtp-inbound1.duck.com[52.146.152.212] refused to talk to me: 554 host [xx.xxx.xx.xxx] is blacklisted by zen.dnsbl)
Oct 25 20:11:39 pbs systemd[1]: Reloading Postfix Mail Transport Agent (instance -).
Oct 25 20:11:40 pbs postfix/master[807]: reload -- version 3.5.18, configuration /etc/postfix
Oct 25 20:11:40 pbs systemd[1]: Reloaded Postfix Mail Transport Agent (instance -).
 
Hi!
I think your config did not get reloaded correctly... Did you execute: postfix reload ? You could also try postfix check to check that all configurations have been applied correctly.
The documentation is here: http://www.postfix.org/BASIC_CONFIGURATION_README.html
Thank you . I managed to fix it by setting up a sasl_passwd file. I had thought pbs would use the proxmox node email settings since it was a vm in the same host.
all is good thanks.
 
  • Like
Reactions: ggoller

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!