[SOLVED] Elasticsearch cluster over vxlan

Astaoth

New Member
Aug 31, 2021
3
0
1
52
Hi,

I've encountered a weird behaviour when building an Elasticsearch cluster over a Proxmox cluster :
I have a 2 node cluster (with an additional corosync node running on a rpi for the HA), on which I run only LXC. On this, I have an intra-cluster vxlan, in order to have a common internal LAN for my LXC. I also have on each node a bridge for giving external access to my LXC if necessary.

Then, on this cluster, I have deployed an Elasticsearch cluster with :
- on each proxmox node, a master/data node
- an additionnal master node which can be migrated between each proxmox node, for having a kind of HA which is enough for my setup

When the ElasticSearch nodes listen on the external bridge interfaces, the cluster can work fine, each nodes are visible.
However, when this nodes listen on the vxlan interfaces, only the two which are on the same Proxmox node are visible, the one on the other promox node can't be connected to the ElasticSearch cluster. But with a telnet or nc command I can reach the 9200 and 9300 of each ElasticSearch nodes from every ElasticSearch LXC.

Do you have an idea of how to correct this strange behaviour over the vxlan ?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!