[SOLVED] Dual Linux bridge not working


Oct 28, 2016
Trying to setup pfSense on Proxmox by following the guide from netgate but I can't access the VM host via IP unless I comment out the 1st Linux Bridge as shown below.

[INDENT]auto lo
iface lo inet loopback

auto eno1
iface eno1 inet static

auto eno2
iface eno2 inet manual

#auto vmbr1
#iface vmbr1 inet manual
#       bridge-ports eno1
#       bridge-stp off
#       bridge-fd 0

auto vmbr2
[INDENT]iface vmbr2 inet manual
        bridge-ports eno2
        bridge-stp off
        bridge-fd 0[/INDENT][/INDENT]
Yes, the box has dual Ethernet
root@ML10:~# dmesg | grep eth
[    0.955459] tg3 0000:03:00.0 eth0: Tigon3 [partno(N/A) rev 5720000] (PCI Express) MAC address 30:8d:99:cc:96:c0
[    0.955461] tg3 0000:03:00.0 eth0: attached PHY is 5720C (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[1])
[    0.955462] tg3 0000:03:00.0 eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[1] TSOcap[1]
[    0.955463] tg3 0000:03:00.0 eth0: dma_rwctrl[00000001] dma_mask[64-bit]
[    0.975031] tg3 0000:03:00.1 eth1: Tigon3 [partno(N/A) rev 5720000] (PCI Express) MAC address 30:8d:99:cc:96:c1
[    0.975033] tg3 0000:03:00.1 eth1: attached PHY is 5720C (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[1])
[    0.975034] tg3 0000:03:00.1 eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[1] TSOcap[1]
[    0.975035] tg3 0000:03:00.1 eth1: dma_rwctrl[00000001] dma_mask[64-bit]
[    0.975744] tg3 0000:03:00.1 eno2: renamed from eth1
[    0.992198] tg3 0000:03:00.0 eno1: renamed from eth0

Any suggestions?? Once I get pfSense working for a few days I do plan to buy an Intel PCI-E dual gigabit ethernet card but would prefer to prove this will work.
try configuring the ip,netmask,gateway on the 'vmbr1' instead of on the 'eno1' which is put inside 'vmbr1'
Your config is wrong.

Move the actual ip and other settings to the bridge.
Should be

iface eno1 inet manual
Auto vmbr0## inet <whatever>
And all the settings here including bridge specific entries.

It works but you may need 3 mics for easier setup.
I am running pfsence vm now on proxmox setup.
It is a dedicated box but still a vm on proxmox.
I have 3 nics.
So etho is dedicated to vmbr0 and is system, ie. Proxmox management

Eth1 is on vmbr1 dedicated to WAN. Dhcp
Eth2 is on vmbr2 dedicated to LAN. No ip.
Pfsence vm attached to vmbr1 as WAN and vmbr2 as LAN.
Eth1 plugged into my cable modem.
Eth2 and eth0 plugged in to my 24 port switch.

In your case it will be vmbr1 as WAN and vmbr0 as LAN and management.
You may need to add aliase up to it for proxmox host as pfsence will be your gateway.
@Stoiko - your suggestion worked, huge thanks!

@jim.bond.9862 - yes I plan to add another NIC. More than likely this will not be as power efficient as say a USG Pro or EdgeRouter 4 but that wouldn't be as much fun. Already have the box running as a NAS and hosting a few VMs
  • Like
Reactions: Stoiko Ivanov
Have fun.
You can always invest 2-3 hundred down the road on an hp t730 client. Load it up with proxmox and move the vm there.
It would be just as efficient as edgerouter but more powerful. I think...


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!