[SOLVED] dont have access to gui and command line

peiman

Member
Sep 21, 2016
16
0
6
37
hi
i have no access to gui and also command line
but vm are working good

this is my log
what can cause this issue!?

Code:
root@m3784:~# systemctl status pvestatd.service
● pvestatd.service - PVE Status Daemon
   Loaded: loaded (/lib/systemd/system/pvestatd.service; enabled)
   Active: failed (Result: exit-code) since Tue 2019-05-07 05:52:38 CEST; 4 days ago
 Main PID: 1461 (code=exited, status=255)

May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: ipcc_send_rec failed: Connection refused
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: ipcc_send_rec failed: Connection refused
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: ipcc_send_rec failed: Connection refused
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: restarting server after 785573 cycles to reduce memory usage (free 72003584 (5251072) bytes)
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: server shutdown (restart)
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: Can't exec "/usr/bin/pvestatd": No such file or directory at /usr/share/perl5/PVE/Daemon....ne 518.
May 07 05:52:38 m3784.contaboserver.net systemd[1]: pvestatd.service: main process exited, code=exited, status=255/n/a
May 07 05:52:38 m3784.contaboserver.net systemd[1]: Unit pvestatd.service entered failed state.
May 11 18:34:25 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 18:37:02 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
Hint: Some lines were ellipsized, use -l to show in full.
root@m3784:~# qm list
ipcc_send_rec[1] failed: Connection refused
ipcc_send_rec[2] failed: Connection refused
ipcc_send_rec[3] failed: Connection refused
Unable to load access control list: Connection refused
root@m3784:~# qm config 101 | grep ^memory
ipcc_send_rec[1] failed: Connection refused
ipcc_send_rec[2] failed: Connection refused
ipcc_send_rec[3] failed: Connection refused
Unable to load access control list: Connection refused
 
it seems the system is out of memory
restart is a good idea ?!

Code:
root@m3784:~# pveversion -v
proxmox-ve: not correctly installed (running kernel: 4.4.67-1-pve)
pve-manager: not correctly installed (running version: 5.4-5/c6fdb264)
pve-kernel-4.15: 5.4-2
pve-kernel-4.15.18-14-pve: 4.15.18-38
pve-kernel-4.4.67-1-pve: 4.4.67-92
pve-kernel-4.4.13-1-pve: 4.4.13-56
corosync: 2.4.4-pve1
criu: 1.6.0-1
glusterfs-client: 3.5.2-2+deb8u3
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-9
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-51
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-13
libpve-storage-perl: 5.0-42
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.116-pve3
lxc-pve: 2.0.7-4
lxcfs: 2.0.7-pve2
novnc-pve: 0.5-9
proxmox-widget-toolkit: 1.0-26
pve-cluster: 5.0-37
pve-container: 2.0-37
pve-docs: 5.0-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-20
pve-firmware: 2.0-2
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.12.8-2
pve-qemu-kvm: 3.0.1-2
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-51
smartmontools: 6.5+svn4324-1~pve80
spiceterm: 3.0-5
vncterm: 1.3-2
zfsutils-linux: 0.6.5.9-pve16~bpo90
 
i got this error now

Code:
root@m3784:~# apt-get install proxmox-ve
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  corosync-pve libasprintf0c2 libcorosync4-pve libdirectfb-1.2-9 libiscsi4 libpango1.0-0 linux-base python-support
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  proxmox-ve
0 upgraded, 1 newly installed, 0 to remove and 190 not upgraded.
1 not fully installed or removed.
Need to get 7,300 B of archives.
After this operation, 25.6 kB of additional disk space will be used.
Get:1 http://download.proxmox.com/debian/pve stretch/pvetest amd64 proxmox-ve all 5.4-1 [7,300 B]
Fetched 7,300 B in 0s (34.8 kB/s)
Selecting previously unselected package proxmox-ve.
(Reading database ... 51656 files and directories currently installed.)
Preparing to unpack .../proxmox-ve_5.4-1_all.deb ...
Unpacking proxmox-ve (5.4-1) ...
Setting up pve-manager (5.4-5) ...
Job for pvestatd.service failed. See 'systemctl status pvestatd.service' and 'journalctl -xn' for details.
dpkg: error processing package pve-manager (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of proxmox-ve:
 proxmox-ve depends on pve-manager; however:
  Package pve-manager is not configured yet.

dpkg: error processing package proxmox-ve (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pve-manager
 proxmox-ve
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
i got this error now

Code:
root@m3784:~# apt-get install proxmox-ve
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  corosync-pve libasprintf0c2 libcorosync4-pve libdirectfb-1.2-9 libiscsi4 libpango1.0-0 linux-base python-support
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  proxmox-ve
0 upgraded, 1 newly installed, 0 to remove and 190 not upgraded.
1 not fully installed or removed.
Need to get 7,300 B of archives.
After this operation, 25.6 kB of additional disk space will be used.
Get:1 http://download.proxmox.com/debian/pve stretch/pvetest amd64 proxmox-ve all 5.4-1 [7,300 B]
Fetched 7,300 B in 0s (34.8 kB/s)
Selecting previously unselected package proxmox-ve.
(Reading database ... 51656 files and directories currently installed.)
Preparing to unpack .../proxmox-ve_5.4-1_all.deb ...
Unpacking proxmox-ve (5.4-1) ...
Setting up pve-manager (5.4-5) ...
Job for pvestatd.service failed. See 'systemctl status pvestatd.service' and 'journalctl -xn' for details.
dpkg: error processing package pve-manager (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of proxmox-ve:
 proxmox-ve depends on pve-manager; however:
  Package pve-manager is not configured yet.

dpkg: error processing package proxmox-ve (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pve-manager
 proxmox-ve
E: Sub-process /usr/bin/dpkg returned an error code (1)
Dependencies is missing.
Try install pve-manager first
 
i tried and got
Code:
root@m3784:~# sudo apt-get install pve-manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
pve-manager is already the newest version (5.4-5).
0 upgraded, 0 newly installed, 0 to remove and 188 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up pve-manager (5.4-5) ...
Job for pvestatd.service failed. See 'systemctl status pvestatd.service' and 'journalctl -xn' for details.
dpkg: error processing package pve-manager (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of proxmox-ve:
 proxmox-ve depends on pve-manager; however:
  Package pve-manager is not configured yet.

dpkg: error processing package proxmox-ve (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pve-manager
 proxmox-ve
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
nothing!!

Code:
root@m3784:~# apt remove pve-manager && apt install -y proxmox-ve pve-manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  apparmor apt-transport-https bridge-utils ceph-common ceph-fuse cifs-utils corosync criu cstream dtach ebtables faketime fonts-font-awesome gdisk genisoimage
  glusterfs-client glusterfs-common hdparm ifenslave ipset javascript-common libanyevent-http-perl libanyevent-perl libapparmor-perl libappconfig-perl libapt-pkg-perl
  libarchive13 libasound2 libasound2-data libasync-interrupt-perl libasyncns0 libauthen-pam-perl libboost-iostreams1.62.0 libboost-system1.55.0 libboost-system1.62.0
  libboost-thread1.55.0 libboost-thread1.62.0 libcaca0 libcephfs1 libcfg6 libclone-perl libcmap4 libcorosync-common4 libcpg4 libcrypt-openssl-bignum-perl
  libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcurl3-gnutls libdbi1 libdevel-cycle-perl libev-perl libfaketime libfdt1 libfile-chdir-perl
  libfile-readbackwards-perl libfilesys-df-perl libflac8 libgnutlsxx28 libgoogle-perftools4 libguard-perl libibverbs1 libice6 libio-multiplex-perl libio-stringy-perl
  libipset3 libiscsi7 libjasper1 libjemalloc1 libjs-extjs libjs-jquery libjson-c3 libldb1 liblinux-inotify2-perl liblzo2-2 libmime-base32-perl libnet-dbus-perl
  libnet-dns-perl libnet-ip-perl libnetfilter-conntrack3 libnetfilter-log1 libnspr4 libnss3 libnuma1 libogg0 libpng12-0 libprotobuf-c1 libprotobuf9 libpulse0
  libpve-access-control libpve-apiclient-perl libpve-common-perl libpve-guest-common-perl libpve-http-server-perl libpve-storage-perl libpve-u2f-server-perl
  libpython2.7 libqb0 libquorum5 librados2 librados2-perl librbd1 librdmacm1 librrd4 librrd8 librrds-perl libsdl1.2debian libseccomp2 libsm6 libsmbclient libsnappy1v5
  libsndfile1 libstatgrab10 libstring-shellquote-perl libtalloc2 libtcmalloc-minimal4 libtdb1 libtemplate-perl libtevent0 libtie-ixhash-perl libtotem-pg5
  libu2f-server0 libunwind8 libusbredirparser1 libuuid-perl libvorbis0a libvorbisenc2 libvotequorum8 libwbclient0 libx11-xcb1 libxml-libxml-perl libxml-twig-perl
  libxml-xpathengine-perl libxslt1.1 libxtst6 lxc-pve lxcfs lzop novnc-pve numactl proxmox-widget-toolkit pve-cluster pve-container pve-docs pve-edk2-firmware
  pve-firewall pve-ha-manager pve-i18n pve-libspice-server1 pve-qemu-kvm pve-xtermjs python-blinker python-ceph python-cffi python-chardet python-cryptography
  python-flask python-ipaddr python-itsdangerous python-jinja2 python-markupsafe python-ndg-httpsclient python-openssl python-pkg-resources python-ply python-protobuf
  python-pyasn1 python-pycparser python-pyinotify python-requests python-six python-talloc python-urllib3 python-werkzeug qemu-server rrdcached samba-common
  samba-libs smbclient socat spiceterm sqlite3 uidmap vncterm x11-common xsltproc
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  proxmox-ve pve-manager
0 upgraded, 0 newly installed, 2 to remove and 65 not upgraded.
2 not fully installed or removed.
After this operation, 9,718 kB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 51977 files and directories currently installed.)
Removing proxmox-ve (5.4-1) ...
Removing pve-manager (5.4-5) ...
Processing triggers for man-db (2.7.6.1-2) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libjasper1 libpng12-0 librrd4
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  proxmox-ve pve-manager
0 upgraded, 2 newly installed, 0 to remove and 65 not upgraded.
Need to get 0 B/1,969 kB of archives.
After this operation, 9,718 kB of additional disk space will be used.
Selecting previously unselected package pve-manager.
(Reading database ... 51389 files and directories currently installed.)
Preparing to unpack .../pve-manager_5.4-5_amd64.deb ...
Unpacking pve-manager (5.4-5) ...
Selecting previously unselected package proxmox-ve.
Preparing to unpack .../proxmox-ve_5.4-1_all.deb ...
Unpacking proxmox-ve (5.4-1) ...
Setting up pve-manager (5.4-5) ...
Job for pvestatd.service failed. See 'systemctl status pvestatd.service' and 'journalctl -xn' for details.
dpkg: error processing package pve-manager (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for man-db (2.7.6.1-2) ...
dpkg: dependency problems prevent configuration of proxmox-ve:
 proxmox-ve depends on pve-manager; however:
  Package pve-manager is not configured yet.

dpkg: error processing package proxmox-ve (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pve-manager
 proxmox-ve
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Code:
root@m3784:~# df -h
Filesystem      Size  Used Avail Use% Mounted on
udev             10M     0   10M   0% /dev
tmpfs            26G  2.5G   23G  10% /run
/dev/sda2       474G  387G   64G  86% /
tmpfs            63G     0   63G   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs            63G     0   63G   0% /sys/fs/cgroup
/dev/sda1       226M  123M   87M  59% /boot


tell me what happens if i restart my server? is it possible to damage on working vm's?!
 
Unless you want more downtime if it doesn't work?

Code:
apt clean && apt remove pve-manager && apt install -y proxmox-ve pve-manager

Hopefully this should download fresh packages from the repository, if you still having problem afterwards, then looking at the error message could be helpful. (eg. systemctl status pvestatd) If it's different from the above; then of course the problem is elsewhere.

Good Luck.
 
Code:
apt clean && apt autoremove pve-manager && apt install -y proxmox-ve pve-manager
 
see
this is the out put

Code:
root@m3784:~# systemctl status pvestatd
● pvestatd.service - PVE Status Daemon
   Loaded: loaded (/lib/systemd/system/pvestatd.service; enabled)
   Active: failed (Result: exit-code) since Tue 2019-05-07 05:52:38 CEST; 4 days ago
 Main PID: 1461 (code=exited, status=255)

May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: ipcc_send_rec failed: Connection refused
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: ipcc_send_rec failed: Connection refused
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: ipcc_send_rec failed: Connection refused
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: ipcc_send_rec failed: Connection refused
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: restarting server after 785573 cycles to reduce memory usage (fr...ytes)
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: server shutdown (restart)
May 07 05:52:37 m3784.contaboserver.net pvestatd[1461]: Can't exec "/usr/bin/pvestatd": No such file or directory at /us... 518.
May 07 05:52:38 m3784.contaboserver.net systemd[1]: pvestatd.service: main process exited, code=exited, status=255/n/a
May 07 05:52:38 m3784.contaboserver.net systemd[1]: Unit pvestatd.service entered failed state.
May 11 18:34:25 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 18:37:02 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 20:20:40 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 20:21:59 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 21:10:25 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 21:10:37 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 21:10:52 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 21:11:21 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 21:11:32 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 21:17:29 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 21:18:27 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 21:19:23 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
May 11 21:46:24 m3784.contaboserver.net systemd[1]: Unit pvestatd.service cannot be reloaded because it is inactive.
Hint: Some lines were ellipsized, use -l to show in full.
 
upgrade to last version fixed my problem

Code:
apt-get update && apt-get dist-upgrade
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!