DNS not resolving but external IP Addresses can be pinged


New Member
Nov 7, 2023
I'm hosting proxmox on an Azure VM. I have successfully installed it and just setup my network interfaces. When I try to ping or curl any domain names it fails and cannot resolve. Here's what I've tried

In Azure I have set custom DNS to and which automatically updated resolve.conf with:
search .

Bash:    localhost        proxmox-vm
::1        localhost ip6-localhost ip6-loopback
ff02::1        ip6-allnodes
ff02::2        ip6-allrouters

My interfaces config looks like:
auto lo
iface lo inet loopback

iface eth0 inet manual

auto vmbr0

iface vmbr0 inet static
    bridge-ports eth0
    bridge-stp on
    bridge-fd 0

I have also tried adding dns_nameservers on vmbr0 but that made no difference. I can access my proxmox Web GUI from it's public IP without issues. I've also ensured that there are no ports blocked on Azure's security group, I was able to setup proxmox and access external services, but now that vmbr is setup I cannot. I'm stuck!


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!