[SOLVED] Disable automatic updating of package index

Hummbla

New Member
Dec 20, 2021
2
0
1
24
Hello!
As i'm moving more and more towards Ansible for configuration and update management i would also like to use it for my Proxmox hosts.
That works just fine, but there is one annoyance that i would like to get rid of:
Proxmox automatically updates the package index, i would like to handle that myself using Ansible. (I'm nitpicking at this point :p )
I want to disable the automatic package index update because Ansible is going to do that for me anyways (Doing it twice is pretty useless if i do it on a regular basis anyways).

Is there a configuration for disabling the automatic update? I've briefly looked through the daily cronjobs but i couldn't find it.

Im running Proxmox with the non-subscription mirrors (Version: Virtual Environment 7.1-8).

Best regards
Hummbla
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
705
118
hi,

you can just do systemctl disable pve-daily-update.timer (it's a systemd timer not a cronjob ;) )

but automatic update won't upgrade the packages, it basically runs apt update. why does that bother you?
 
  • Like
Reactions: Hummbla

Hummbla

New Member
Dec 20, 2021
2
0
1
24
Howdy,
Thanks for the fast reply! Reaching out twice to the repository mirror is not really required (in this case), i don't want to take bandwidth i don't need :)

Like i said, its basically just nitpicking, thanks for the solution.
Have a great day and stay healthy!

Best regards
Hummbla
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!