dev/mapper/pve-root not activated at boot after upgrade to Proxmox 8

Attila

Active Member
Jun 15, 2016
13
0
41
Hi.

I have upgraded to Proxmox 8, and since then I am having boot issues.
My storage is a sw raid-1, with a plain boot partition, and a luks encrypted root partition. The pve VG is on top of a luks-encrypted, raid1 setup.
It all worked fine, before the upgrade. I entered the passphrase on boot, pve vg was recognized, root was mounted (/dev/mapper/pve-root).

After the upgrade the following happens:
1698922938192.png

If I enter lvm, then do a vgscan and vgchange -a y, the partitions are activated.
I exit from initramfs prompt and the system boots properly.

Unfortunately this happens on every boot. How could I fix this?
I tried to play with some lvm.conf settings, and update-initramfs but no luck.

Any ideas?
 
No ideas? How could I execute a vgscan and vgchange command in initramfs AFTER the passphrase to unlock the PV of the root logical volume was entered?
 
Since I did not get any useful hints, I decided to reorganize my setup - I changed the root partition to unencrypted. The issue appeared to be that the volume group (which held the root volume) consited of two encrypted phisical volumes, and only one was decrypted on time...
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!