Delay to log in SSH session after upgrade from 6.x to 7.x

logicheart

New Member
Jun 2, 2021
11
1
3
47
Hello

After upgrading Proxmox Mail Gateway from 6.x to 7.x version i detect a delay to enter in SSH sessions.

This is happening with Putty, WinSCP or Web shell where before i was instantly logged into sessions now i have to wait about 30+ seconds to log in.

Mail Gateway is installed in a Linux container.

Is anyone come across this?

Thank you in advance

Best regards
 

Dominic

Proxmox Staff Member
Staff member
Mar 18, 2019
1,388
167
68
Could you please try to login with verbose output?

Code:
ssh -vvv ...

And post from the host
Code:
pct config <containerid>
and from within the container
Code:
journalctl -b
pmgversion -v
dpkg -l | grep dbus
 
Last edited:
  • Like
Reactions: Stoiko Ivanov

logicheart

New Member
Jun 2, 2021
11
1
3
47
Hello

Below are the output of commands:

pct config <containerid>
arch: amd64
cores: 1
description: Role%3A Email Gateway Server%0A%0APlatform%3A Proxmox Mail Gateway%0A
hostname:
memory: 4096
nameserver: 192.168.0.x
net0: name=eth0,bridge=vmbr0,gw=192.168.0.y,hwaddr=6A:2B:5B:2B:F4:AF,ip=192.168.0.z/24,type=veth
onboot: 1
ostype: debian
parent: First
rootfs: local-zfs:subvol-104-disk-0,size=15G
searchdomain:
startup: order=1,up=0,down=0
swap: 0
unprivileged: 1

pmgversion -v
proxmox-mailgateway-container: 7.0-1 (API: 7.0-6/773780b0, running kernel: 5.4.124-1-pve)
pmg-api: 7.0-6
pmg-gui: 3.0-3
clamav-daemon: 0.103.2+dfsg-2
libarchive-perl: 3.4.0-1
libjs-extjs: 7.0.0-1
libjs-framework7: 4.4.7-1
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.0-4
libpve-http-server-perl: 4.0-2
libxdgmime-perl: 1.0-1
lvm2: not correctly installed
pmg-docs: 7.0-2
pmg-log-tracker: 2.2.0-1
postgresql-13: 13.3-1
proxmox-mini-journalreader: 1.2-1
proxmox-spamassassin: 3.4.6-3
proxmox-widget-toolkit: 3.3-4
pve-xtermjs: 4.12.0-1

dpkg -l | grep dbus
ii dbus 1.12.20-2 amd64 simple interprocess messaging system (daemon and utilities)
ii libdbus-1-3:amd64 1.12.20-2 amd64 simple interprocess messaging system (library)
ii libnet-dbus-perl 1.2.0-1+b1 amd64 Perl extension for the DBus bindings

Command journalctl -b gives an output of 2000+ lines. Is there something particular from this text which i can send?

Best regards
 

Dominic

Proxmox Staff Member
Staff member
Mar 18, 2019
1,388
167
68
Thank you! Looks like I had the same problem. I could resolve it by activating nesting:

Code:
sudo pct set 137 --features nesting=1
sudo pct stop 137
sudo pct start 137
(replace 137 by your container ID)


Command journalctl -b gives an output of 2000+ lines. Is there something particular from this text which i can send?
Does it contain
Code:
Failed to set up mount namespacing
?
That's one of the messages that should go away when activating nesting.
 
  • Like
Reactions: Stoiko Ivanov

logicheart

New Member
Jun 2, 2021
11
1
3
47
It works alright now! Log in is fast lightning and the message has indeed disappeared from logs.

Thank you for all your help!
 
  • Like
Reactions: Dominic

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!