I try to create a bundle with interface which will be used as a multi-vlan trunk. I thought config was very straightforward, but it doesn't seem to work...
Switch config:
Proxmox configured via GUI, bond with the 2 physical interfaces and linux bridge per VLAN bound to the bond subinterface.
Output in /etc/network/interfaces:
Seems not to be working, i can't even ping my GW...
Switch config:
Code:
interface GigabitEthernet1/0/x
switchport trunk allowed vlan 1000,1001
switchport mode trunk
channel-group 1 mode active
interface GigabitEthernet1/0/y
switchport trunk allowed vlan 1000,1001
switchport mode trunk
channel-group 1 mode active
interface Port-channel1
switchport trunk allowed vlan 1000,1001
switchport mode trunk
Output in /etc/network/interfaces:
Code:
auto lo
iface lo inet loopback
auto ens3f0
iface ens3f0 inet manual
#Management
auto ens3f1
iface ens3f1 inet manual
#Data
auto ens2f0
iface ens2f0 inet static
address 169.254.0.1
netmask 30
#Sync
auto ens2f1
iface ens2f1 inet manual
#Data
auto bond0
iface bond0 inet manual
bond-slaves ens2f1 ens3f1
bond-miimon 100
bond-mode 802.3ad
bond-xmit-hash-policy layer2+3
#Data - LACP
auto vmbr0
iface vmbr0 inet static
address x.x.x.x
netmask 24
gateway x.x.x.y
bridge-ports ens3f0
bridge-stp off
bridge-fd 0
#Management
auto vmbr1000
iface vmbr1000 inet manual
bridge-ports bond0.1000
bridge-stp off
bridge-fd 0
#VLAN 1000
auto vmbr1001
iface vmbr1001 inet manual
bridge-ports bond0.1001
bridge-stp off
bridge-fd 0
#VLAN 1001