Create zfs fails - gui


Jul 22, 2017

pveversion --verbose
proxmox-ve: 5.3-1 (running kernel: 4.15.18-9-pve)
pve-manager: 5.3-5 (running version: 5.3-5/97ae681d)
pve-kernel-4.15: 5.2-12
pve-kernel-4.15.18-9-pve: 4.15.18-30
pve-kernel-4.15.17-1-pve: 4.15.17-9
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-3
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-43
libpve-guest-common-perl: 2.0-18
libpve-http-server-perl: 2.0-11
libpve-storage-perl: 5.0-33
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.0.2+pve1-5
lxcfs: 3.0.2-2
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-22
pve-cluster: 5.0-31
pve-container: 2.0-31
pve-docs: 5.3-1
pve-edk2-firmware: 1.20181023-1
pve-firewall: 3.0-16
pve-firmware: 2.0-6
pve-ha-manager: 2.0-5
pve-i18n: 1.0-9
pve-libspice-server1: 0.14.1-1
pve-qemu-kvm: 2.12.1-1
pve-xtermjs: 1.0-5
qemu-server: 5.0-43
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.12-pve1~bpo1

I'm trying to setup a zfs from 2x3TB disk in mirror as seen on the image below.

After clicking "create" I get the following error:

"command '/sbin/zpool create -o 'ashift=12' storage mirror /dev/sdc /dev/sdd' failed: exit code 1"

Creating a single disk also fails.

What could be wrong?
Try to run the command in the shell - the output should give an indication where the problem lies (alternatively click on the taks log for the task (bottom of the GUI).
If this doesn't help - check the output of `dmesg` and `journalctl -r`
  • Like
Reactions: ZooKeeper
bet one of the disks has been a member of an exported pool, use -f to force.
I did the commands in terminal.
It complaint about corrupt EFI label
root@basement:~# /sbin/zpool create -o ashift=12 homemedia mirror /dev/sdc /dev/sdd
invalid vdev specification
use '-f' to override the following errors:
/dev/sdc contains a corrupt primary EFI label.
/dev/sdd contains a corrupt primary EFI label.

I had done
dd if=/dev/zero of=/dev/sdd bs=1M count=1
on them both...

I redid the command with -f and it seems to work now.
For future readers: I can confirm that this method worked for me on Proxmox 6.0

Enter the command in the shell rather than relying on the GUI, but add the "-f" option.

"/sbin/zpool create -f -o 'ashift=12' ThePool mirror /dev/sdc /dev/sdd mirror /dev/sde /dev/sdf"

Sorry to necro the thread, but there wasn't a clear solution stated for future users.

Thanks, VVyatt
Hi Guys,

I had this issue in 6.2-4 what i did to fix it is in shell

mkfs.ext4 /dev/sda "change sda to your drive "
fdisk /dev/sda "change sda to your drive "
then w to write

Hope this helps

Hi Guys,

I had this issue in 6.2-4 what i did to fix it is in shell

mkfs.ext4 /dev/sda "change sda to your drive "
fdisk /dev/sda "change sda to your drive "
then w to write

Hope this helps

Worked form me. I had two 4TB drives and one of them would give me that error. Thanks.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!