Corosync-Qdevice Operating Problem


New Member
Jul 9, 2023
Hello everyone !

I have already set up a QDevice (which is Raspberry Pi) in a two node cluster. I didn't have any problems during the installation process. I can ssh the qdevice from each node without any problems. I am using 2FA authentication and also I have changed the default ssh port on each device. The ICMP protocol is set to ACCEPT in the /etc/ufw/before.rules file of the nodes and the qdevice.

Here are a few commands results :

pvecm status


pvecm nodes


systemctl status pve-cluster corosync -l


Everything looks ok until I reboot one of the nodes. I get Quorate: No and I am not able to access any of the nodes (the other one).

What am I missing guys ?
Thank you in advance :)!
Hello, from pvecm status you have one node with the NA (not alive) flag, that means that it cannot reach the qdevice, how did you set up the qdevice? You need to install the package (corosync-qdevice) on all the nodes of a cluster for it to work, also make sure all machines can ping and see each other over the network.
Hello !
Thank you very much for your response and attention.

I can ping each device from each device without any problems. I have already installed the corosync-device on the 2 nodes.


Also on the raspberry pi :

sudo apt install corosync-qnetd corosync-qdevice


I thing the problem is in any on of the conf. files. Do you know any other command which I can run and give you the result ?
Again thanks !
Note that installing corosync-qdevice on the raspberry pi is not needed, I don't think this is an issue but it is a good idea to remove it.

Just to be sure, when you say that each device can be pinged you mean that each of the three devices can see by the other two right? Note that node 2 cannot communicate with the raspberry pi.

How did you setup the qdevice? Did you create the qdevice after the 2-node cluster was formed? I would advice to remove the qdevice and add it again (after removing the unneded package from the raspberry) and test if this improves the situation.

See our docs for qdevice, specially the FAQ.
Thanks for your reply !

I would go with removing the qdevice and try to set it up again. Just to ask should I remove any conf. files or only the corosync-qdevice on the 2 nodes and on the raspberry pi ?
If you used our tooling to install the device pvecm qdevice remove should work without the need of clearing conf files. Please see the docs I linked above.
  • Like
Reactions: nakata720
For everyone encountering obstacles while setting up the qdevice with 2 nodes - all the devices with configured 2FA authentication.
  1. What I have done is reinstall proxmox on the 2 nodes and ensure that they are with different host names.
  2. Set port 22 for ssh communication and add it to your ufw
  3. In /etc/ssh/sshd_config set these settings for temporary use (These steps should be done on each device and after the installation should be reverted! ):
    1. PasswordAuthentication yes
    2. ChallengeResponseAuthentication no
    3. Comment the AuthenticationMethods line where you describe the auth methods you are using (if there is such one)
    4. Comment UsePam
  4. Save and restart sshd service
  5. Allow port 5403/tcp on the qdevice
  6. Then from the documentation I followed the steps and successfully configured the qdevice
  7. BackUp each device :D
I hope I helped somebody.
Again thanks to Maximiliano !
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!