Corosync already exists


New Member
Feb 4, 2019
I want to add a new node to my cluster. The cluster already has 9 nodes on it and they were added without issue. The node I want to add is a fresh installation and I have checked that all the pve services are running correctly.

When I log onto node 1 and run:

pvecm add

I get this:

detected the following error(s):
* authentication key '/etc/corosync/authkey' already exists
* cluster config '/etc/pve/corosync.conf' already exists
* this host already contains virtual guests
* corosync is already running, is this node already in a cluster?!

How is this possible?

So I tried:

pvecm add --force

and I now get:

Request addition of this node
500 can't open '/etc/corosync/authkey' - No such file or directory

I don't understand what is going on here. Can someone please help?
  • Like
Reactions: webardo
`pvecm add` needs to be run on the new node, which you try to add to the cluster (see `man pvecm`)

I guess you tried to run it on the existing node - and with the second run (with --force) you kicked one of your nodes out of the cluster (the one you ran the command on)

please post the output of `pvecm status` (on the node you ran the commands on and one other node in the cluster)
You can mark the thread as 'SOLVED' on your own - just click on 'Thread Tools' -> 'Edit Thread' -> add the prefix '[SOLVED]'

It would be great if you shortly write what the problem was - it could help other in your situation



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!