Container Version does not save settings properly

Discussion in 'Mail Gateway: Installation and configuration' started by dthompson, Apr 6, 2019.

  1. dthompson

    dthompson Member

    Joined:
    Nov 23, 2011
    Messages:
    38
    Likes Received:
    0
    I'm starting to look into moving from a KVM over to a LXC container for my filters.

    I've set one up, but every time I go to make a change to some of the settings, seemingly the ones that require postfix modification, I am getting the following error:

    update config section 'mail' failed: command 'systemctl restart postfix@-' failed: exit code 1 (500)

    I get this when I look at the status of postfix:

    systemctl status postfix.service
    ‚óŹ postfix.service - Postfix Mail Transport Agent
    Loaded: loaded (/lib/systemd/system/postfix.service; enabled; vendor preset: enabled)
    Active: active (exited) since Sat 2019-04-06 08:32:58 EDT; 2h 26min ago
    Process: 253 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
    Main PID: 253 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 629145)
    CGroup: /system.slice/postfix.service

    Apr 06 08:32:58 swarmx1 systemd[1]: postfix.service: Failed to reset devices.list: Operation not permitted
    Apr 06 08:32:58 swarmx1 systemd[1]: Starting Postfix Mail Transport Agent...
    Apr 06 08:32:58 swarmx1 systemd[1]: Started Postfix Mail Transport Agent.
    Apr 06 08:32:58 swarmx1 systemd[1]: postfix.service: Failed to reset devices.list: Operation not permitted

    On my PVE hosts, I am running the following version:
    pve-manager/5.3-11/d4907f84 (running kernel: 4.15.18-9-pve)


    Anyone run into this and if so, what have you done to get around it? I've tried a few different configs of the LXC containers and they all exhibit the same error.

    To test, do the following:

    In your Admin section, go to Configuration --> Mail Proxy --> TLS and try enabling TLS. It will give you the above error and once you close out the actual change, the change is there in the GUI at least. It happens every time I make a change to something.

    However, it doesn't exhibit the issue on Configuration --> Mail Proxy --> Transports.
    That seems to save fine.

    Any thoughts?
     
  2. oguz

    oguz Proxmox Staff Member
    Staff Member

    Joined:
    Nov 19, 2018
    Messages:
    315
    Likes Received:
    26
    Hi,

    This can be ignored safely. The reason postfix is failing is probably something else.

    What kind of Container are you using? Can you post the config? (`pct config CTID`)

    On another note, if you're not already using it, we recently created a new Container for PMG, you should be able to find it among the other templates. (proxmox-mailgateway-5.2-standard_5.2-1_amd64.tar.gz)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dthompson

    dthompson Member

    Joined:
    Nov 23, 2011
    Messages:
    38
    Likes Received:
    0
    Thanks for this and sorry about the late reply. I did use the mail gateway template and thats what caused me the issues. I removed it and then recreated it as an "unprivileged container" and that seems to have done the trick with it and not they are working.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice