Console Black screen

Aska

New Member
Aug 6, 2018
5
1
3
49
Hello community

I have a new issue with proxmox 5, when I open console I have a black screen, and the message "Disconnecting... (Detecting migration...)" I don't understand what it's mean there no migration in progress.

I have change on CT option the typ of console to Shell, it's woorks better but withouit security (no login)

from Ct with Bedian, it's works , but for ubuntu no way (black screen and error connection) I have found

I have found some topic for fix it example (edit all inittabs under /var/lib/vz/root/ ) but I don't have root folder in vz
other solution use ALT+F1, I have try withou succes, somebody have smae trouble and how i can fix it for all CT

for the joke , console for my windows servers works fine ^^

below the CT config first one on debian (console works) second with ubuntu (console on error)


pct config 103

arch: amd64
cpulimit: 2
cpuunits: 1024
hostname: xxxxx
memory: 4192
net0: name=eth0,bridge=vmbr3,hwaddr=86:6B:43:69:C5:2F,type=veth
ostype: debian
rootfs: local:103/vm-103-disk-1.raw,size=60G
swap: 4192
lxc.autodev: 1
lxc.hook.autodev: sh -c "mknod -m 0666 ${LXC_ROOTFS_MOUNT}/dev/fuse c 10 229"


pct config 101

arch: amd64
cores: 4
hostname: xxxxxx
memory: 32768
net0: name=eth0,bridge=vmbr3,hwaddr=AE:1A:03:0C:8E:15,type=veth
ostype: ubuntu
rootfs: local:101/vm-101-disk-1.raw,size=100G
swap: 16384



Proxmox V5


pveversion -v

proxmox-ve: 5.2-2 (running kernel: 4.15.18-1-pve)
pve-manager: 5.2-6 (running version: 5.2-6/bcd5f008)
pve-kernel-4.15: 5.2-4
pve-kernel-4.15.18-1-pve: 4.15.18-17
corosync: 2.4.2-pve5
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.0-8
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-37
libpve-guest-common-perl: 2.0-17
libpve-http-server-perl: 2.0-9
libpve-storage-perl: 5.0-24
libqb0: 1.0.1-1
lvm2: 2.02.168-pve6
lxc-pve: 3.0.0-3
lxcfs: 3.0.0-1
novnc-pve: 1.0.0-2
openvswitch-switch: 2.7.0-3
proxmox-widget-toolkit: 1.0-19
pve-cluster: 5.0-29
pve-container: 2.0-25
pve-docs: 5.2-5
pve-firewall: 3.0-13
pve-firmware: 2.0-5
pve-ha-manager: 2.0-5
pve-i18n: 1.0-6
pve-libspice-server1: 0.12.8-3
pve-qemu-kvm: 2.11.2-1
pve-xtermjs: 1.0-5
qemu-server: 5.0-32
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
 

llamasales

New Member
Mar 13, 2018
4
0
1
40
Mad props for also posting what fixed it for you.
my system hadn't said it needed a reboot for upgrades, but was still listing the broken version until a forced-reboot, after which my consoles worked again.
For the purposes of anyone verifying this bug - root shell works normally, but all consoles are black for 5.2.2
pct enter from root shell works if you need a workaround
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!