ConnectX3 Passthrough fail

Chura

New Member
Jun 2, 2023
5
0
1
Attached ConnectX3 card to my machine, Working fine on the host with bridging to the VMs

1685742734814.png

But when I try to passthrough it to the VM, I get this error

kvm: -device vfio-pci,host=0000:01:00.0,id=hostpci0,bus=pci.0,addr=0x10: vfio 0000:01:00.0: Failed to set up TRIGGER eventfd signaling for interrupt INTX-0: VFIO_DEVICE_SET_IRQS failure: Device or resource busy TASK ERROR: start failed: QEMU exited with code 1

I tried to blacklist the device, mlx4_core/mlx4_ib/mlx4_en, and it was gone from lsmod
but still same error

Any advice ?
 
Last edited:
I did, every part of it. including separation of IOMMU with remapping
root@pxx:~# cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
vfio
vfio_iommu_type1
vfio_pci
vfio_virqfd
 
I apologize for reviving this thread, however, I too am having the same issue. @Chura did you ever get this resolved?
 
I'm sorry buy I can't remember how I fixed it, I think i did not rebuild the kernel after changing the modules, but not sure.
Anyway, I did rollback eventually, since my guest OPNsense had issues with vlans on that passthrough interface which suddenly randomly hanged.
So now using bridges on Proxmox and works awesome.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!