[SOLVED] Connect by sftp on container but not as root

popallo

New Member
Jul 2, 2019
11
0
1
37
Hi Proxmox Community!

After much research on the subject and yet still no concrete answer, I ask for your help to try to resolve an issue on unprivileged containers.

I try by all means to connect on my containers SFTP but without using the root account created by default. Each time I try to connect from another account I get thrown and I can not find a solution.

Why i want to do such thing? Just because I have "web" containers on which I stock website files and I'm wondering if I could edit files without using the host directly by an upload with SFTP.

The use of root account does not please me because I would like to chroot some user and block them to their home directory.

Would anyone have any idea about the feasibility or otherwise of such manipulation?

Thank you in advance to those who can help me move forward.
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
4,107
514
118
This should work without problem..
* How did you create the user inside the container? (which commands)
* How do you try to connect to the container? (again complete sftp-command)
* What errors do you get?

(please use CODE tags for pasted commands/outputs)
 

popallo

New Member
Jul 2, 2019
11
0
1
37
Ok, i'm dumb..

Actually it works well, I just had a configuration problem right on my chrooted directories.
Sorry for the inconvenience :) !

My chrooted directory did not belong to the root user.

Thx for your help ;)
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
4,107
514
118
You're welcome - glad it worked out!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!