[TUTORIAL] Cockpit ZFS Manager


Active Member
Oct 28, 2015
I came across Cockpit and its ZFS manager which works on PVE 6.x fresh install and also PVE 6.X upgrade from pve5to6 with a few ln- s

It can take take of 98% of zfs cli such as trim, attache, detach, replace, snapshot, rollback, clone and etc...

To install cockpit on PVE 6.0,
echo "deb http://deb.debian.org/debian buster-backports main" > /etc/apt/sources.list.d/buster-backport.list;
apt update;
apt-get -t buster-backports install cockpit -y;
apt install git -y;
git clone https://github.com/optimans/cockpit-zfs-manager.git
cp -r cockpit-zfs-manager/zfs /usr/share/cockpit;

systemctl enable cockpit.service;
systemctl start cockpit.service;

#for pve5to6
CMDS="cat grep echo lsblk"
for ONE in $CMDS ; do
  echo -n "Check $ONE in /usr/bin... "
  if [ -e "/usr/bin/$ONE" ]; then
    echo "Exists"
    echo "not exists, do link"
    sudo ln -s /bin/$ONE /usr/bin/$ONE

Please check https://github.com/optimans/cockpit-zfs-manager

Below are some screenshots

Last edited:
  • Like
Reactions: Goggel
Hi, has anybody tried cockpit with proxmox 7? Debian is supported by cockpit but the thing worrying me are all the dependencies cockpit wants to install. I am afraid I will mess up the proxmox.
Damn I really want the ZFS manager....
I ran this and worked a bit better then cockpit on Debian that it recognized root user automatically and was able to use terminal in cockpit but I'm having an issue running updates I get
Cannot refresh cache whilst offline

in logs I see
failed to open /run/network/ifstate when I goto this directory I see that I have ifstatenew
is there a fix for this?
An older post - but does Cockpit work OK on Proxmox 8? A bit scared to break things.
An older post - but does Cockpit work OK on Proxmox 8? A bit scared to break things.
Generally kind of works. Nothing changed in 7 --> 8 inplace upgrade. There are a few peculiarities:
- it never log ins from the first attempt. I have enter credentials --> go to black page --> refresh --> login again
- The network management doesn't work. Cockpit is using Network Manager and the proxmox switches are visible but not editable.
Those issues are OK for me as I only needed the visualization of the zfs only.
The best part - it hasn't broken proxmox, yet :)
Thanks for the update, really appreciate that. I will certainly check it out.
I tried to install cockpit on PVE 8 directly, for ZFS management too. However, it installed a lot of dependencies and I lost SSH connection to it during installation. It seems cockpit somehow interferes with the network.

Now the whole machine disconnects from the router. I am trying to fix it now.

Be careful and make sure you have IPMI or physical access to your machine before installing cockpit.

EDIT: remove unneccessary components can fix network connection
apt autoremove --purge cockpit-storaged cockpit-networkmanager

EDIT2: refer to https://forums.servethehome.com/ind...nux-based-on-cockpit.37500/page-4#post-413670
Just use this instead from the beginning:
apt install -t ${VERSION_CODENAME}-backports cockpit-ws cockpit-bridge cockpit-system
Last edited:
i had an issue with updating thru cockpit saying cannot update offline.
found a post for ubuntu to add
nmcli con add type dummy con-name fake ifname fake0 ip4 gw4
that worked


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!