Cloud-init doesn't configure Netplan network in VM with Debian12


New Member
Sep 18, 2023
We were using Debian11 for our VM in Proxmox and we always used cloud-init to configure Netplan. We are now trying to create a new base VM using Debian12 but something doesn't work. We are using networkd, but when I reboot there's a failure in network configuration.

Here is what I've done:

I enabled the cloud-init service with: systemctl enable cloud-init

With Debian11 we used to give the configuration in a file that we called 01_networkd.cfg in the /etc/cloud/cloud.cfg.d/ folder, with a syntax that I found was a little deprecated, so I tried to adapt the config with the new standard and it's this:

    version: 2
    renderer: networkd
            dhcp4: false
                search: [our_network.priv]
                - to: default

Then I found that Netplan needed openswitch to be installed, so I've done it and then I enabled and applied Netplan configuration:

echo 'ENABLED=1' > /etc/default/netplan
netplan apply

I disabled the networking service, in order to use networkd:

systemctl disable networking; systemctl mask networking
mv /etc/network/{interfaces,}
systemctl enable systemd-networkd

But when I reboot cloud-init gives an error:

[FAILED] Failed to start systemd-networkd-wait-online.service - Wait for Network to be Configured.

Using the Proxmox Console I can see that there's no yaml file in /etc/netplan, so the problem is this: cloud-init doesn't create the network configuration file for Netplan from the config file that I give it.

Any idea? There's something missing or wrong in the syntax?
Thank you.
I think that the problem is that cloud-init leave the netplan config file too open.

I'll explain:
once I netplan apply and then execute cloud-init init I have my netplan config file created, but cloud-init throws this error:
Permissions for /etc/netplan/50-cloud-init.yaml are too open. Netplan configuration should NOT be accessible by others.

So I tried to chmod the file giving it 600 (as requested), check that the permission was changed, then I tried to launch again cloud-init init and I had the same error and the permission was again too open.

There's something I'm missing in this process


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!