Cisco Firepower Threat Defense Virtual for KVM - won't boot


New Member
Jun 5, 2019
Hi all,

I was wondering if anybody cracked the mystery that is FTDv on Proxmox. The issue being that it can't find /dev/sda1 once it bootstrapped itself.

The file i am using is: Cisco_Firepower_Threat_Defense_Virtual-6.2.3-83.qcow2
from here:

The deployment instructions for KVM are here:

I tried the qcow2, raw, vmdk, ova on local storage as well as qm importdisk into lvm. Same result every time.
Virtual Environment 6.0-6

It looks like this.

When i use the above ova/vmdk in vmware workstation, it boots correctly. It looks like this:

So I figured, in vmware workstation, let's see what's wrong with these disks. Nothing looks strange to me.

fdisk shows the disks

I am not sure what is going on. Obviously the boot process is not normal. It bootstraps the asa image first on hd(0,0)
and then tries to find /dev/sda1 to boot from.

Anybody encounter this before?

Thank you,
Last edited:
I would start simple (because that's all I know how to do... ;) )...

Try adjusting various hardware parameters for the VM. Like... use an emulated "IDE" controller instead of "SATA/NVME" or vice versa.
Pretty much. Once I had more time I started trying variations. Stripping out everything that's unnecessary.

Here is the magic that makes it boot for anyone else trying to use free snort with appid.

And then it boots as it should



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!