Chelsio T420-CR cxgb4 not loading "firmware on card (1.19.10) is older than..."

jaysol

New Member
Jul 30, 2019
16
1
3
49
I am seeing the message in startup:

cxgb4 : firmware on card (1.19.10) is older than the version supported with this driver, installing firmware 1.23.4.0 on card.

This would lead you to believe it is updating the firmware on the card right?

Unfortunately no other messages for cxgb4 and I do not see them as interfaces in the system.
 
Any ideas here?

We bought a few of these cards because they were low cost and could be used OOB with FreeBSD, but apparently with Proxmox they may not OOB ready


These Chelsio's CXGBE seems like it should be supported:

https://manpages.debian.org/buster/freebsd-manpages/cxgbe.4freebsd.en.html

From page above, maybe we can just load kernel modules below in loader.conf?

t4fw_cfg_load="YES"
t5fw_cfg_load="YES"
t6fw_cfg_load="YES"
if_cxgbe_load="YES"



Wait a minute....

I was expecting cxgbe* interfaces, but I just noticed in my PVE interface list I now have:

ens1
ens1f4
ens1f4d
1

and when I look up their MAC's they are Chelsio.

So it may be they are found, but just not getting link for some reason.

I guess I'll continue to try to figure this out.
 
Last edited:
I'm using a direct fiber optic cable between PVE and switch port, but not getting link:

TX -> RX
RX -> TX

I've tried swapping the cable TX/RX around just in case, but no change.

Reminds me of the "allow_unsupported_sfp" issue with Intel 10GBE and "unsupported" SFP+ modules but I am not seeing any errors like that.

I guess I could try a couple 1GBE SFP's.
 
Ok looking in DMESG I found this:

[ 3.789865] cxgb4 0000:15:00.4: Direct firmware load for cxgb4/t4-config.txt failed with error -2
[ 4.541838] cxgb4 0000:15:00.4: Successfully configured using Firmware Configuration File "Firmware Default", version 0x0, computed checksum 0x0
[ 4.737838] cxgb4 0000:15:00.4: max_ordird_qp 21 max_ird_adapter 387072
[ 4.871312] cxgb4 0000:15:00.4: 98 MSI-X vectors allocated, nic 16 per uld 16
[ 4.871320] cxgb4 0000:15:00.4: 32.000 Gb/s available PCIe bandwidth (5 GT/s x8 link)
[ 4.907195] cxgb4 0000:15:00.4 eth0: eth0: Chelsio T420-CR (0000:15:00.4) 1G/10GBASE-SFP
[ 4.907445] cxgb4 0000:15:00.4 eth1: eth1: Chelsio T420-CR (0000:15:00.4) 1G/10GBASE-SFP
[ 4.907514] cxgb4 0000:15:00.4: Chelsio T420-CR rev 2
[ 4.907515] cxgb4 0000:15:00.4: S/N: PT32120701, P/N: 110112040E0
[ 4.907516] cxgb4 0000:15:00.4: Firmware version: 1.23.4.0
[ 4.907518] cxgb4 0000:15:00.4: Bootstrap version: 255.255.255.255
[ 4.907519] cxgb4 0000:15:00.4: TP Microcode version: 0.1.9.4
[ 4.907520] cxgb4 0000:15:00.4: No Expansion ROM loaded
[ 4.907521] cxgb4 0000:15:00.4: Serial Configuration version: 0x4271203
[ 4.907522] cxgb4 0000:15:00.4: VPD version: 0x1
[ 4.907523] cxgb4 0000:15:00.4: Configuration: RNIC MSI-X, Offload capable
[ 4.913430] cxgb4 0000:15:00.4 ens1f4: renamed from eth0
[ 4.930056] cxgb4 0000:15:00.4 ens1f4d1: renamed from eth1



But still unable to get link between chelsio and switch.

I've tried CISCO clone SFP+ as well as UNIFI clone SFP+ from ADDON.

I just got some geniune Cisco SFP-10G-SR SFP's so I'll try those next I guess.
 
So for anyone that finds this later on....

CHELSIO T420-CR (and I assume entire T4, T5, T6 series associated w/this driver set) seems to work OOB with PVE 6.x

Once I assigned the NIC to a new vmbr# in proxmox, and rebooted the system, I was able to get link.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!