Changing IP Address is a Nightmare

Jan 13, 2022
19
2
3
42
We need a simple change of the IP address of our Mailgateway.
I did that in Web GUI.
Applying the new setting stopped almost everything. :(

Ping to the new address was working. But anything else not. No WebGUI, no nothing.

Had to restore a Checkpoint.

How can I do this change ?

Please help !
 
  • Like
Reactions: devidhalis07

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
7,562
900
163
33
Vienna
did you also change the ip resolution in /etc/hosts ?
there needs to be at least one ip address that the hostname resolves to, so if you completely changed the ip (and not just added one for example) you have
to adapt the /etc/hosts file to point to the new ip address

for pve, we already have an editor in the gui, but pmg we did not do that yet, if you want, you can open an enhancement request for it here: https://bugzilla.proxmox.com
 
Jan 13, 2022
19
2
3
42
Yes I did change IP address in hosts.
But https://ipaddress:8006 ist not working anymore.
Any other place where I need to change something to make it work ?

An editor for changing pve but not pmg is not really useful. It ruins more than it helps....

By the way I receive this errors when I start :

1643098690345.png

Normal behavior ?
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
7,562
900
163
33
Vienna
do you have a floppy drive (maybe from your idrac/ikvm/ilo/etc. ?)

Any other place where I need to change something to make it work ?
should not be necessary. can you connect via ssh? if yes, can you post the logs? (journalctl)
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
7,562
900
163
33
Vienna
Where can I find journalctl ?
thats the installed command to access the log

could you execute the following commands via ssh and post their output here?

Code:
cat /etc/network/interfaces
cat /etc/hosts
hostname
ss -tlpn
journalct -b -u pmgproxy -u pmgdaemon
curl -k https://localhost:8006/
 
Jan 13, 2022
19
2
3
42
Hi
After deleting hosts and interfaces and recreate them it seems to work.

Only minor poblem is that the hostname is mail2 but the webserver show mail6.
How can I change this banner ?

1643186765365.png

1643186501205.png
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
7,562
900
163
33
Vienna
ah thanks ^^

that should normally be the hostname of the machine, if you changed it, it probably just needs a restart of the pmgproxy
 
Jan 13, 2022
19
2
3
42
1643265907597.png

Now the users also get links with the old name. (mail6.suxeed.com instead of mail2.suxeed.com)
Need a solution urgently !!!
Is you product really v7.1 ? For me it looks more then v0.7.
Such a basic job like renaming an appliance must work.
I'm disappointed.
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
7,562
900
163
33
Vienna
can you please post the output of
Code:
cat /etc/hosts
cat /etc/hostname
hostname
 

birdy

Active Member
May 14, 2021
136
37
28
And I'm disappointed of people experimenting with critical, productive systems without knowledge.

Not only that. Messing up, because of lack of knowledge, and then blaming the product/company. :oops:
 
Last edited:
  • Like
Reactions: wigor and Neobin

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!