[SOLVED] change password failed user .... does not exist


Active Member
Sep 26, 2019
St Louis
I added a user via command-line: pveum user add katycomputer.john@pam

Then tried to set the password via: pveum passwd katycomputer.john@pam

CLI said: change password failed: user 'katycomputer.john' does not exist

So, I tried to replicat via GUI - no joy, any idea where I went wrong?

I belive you have to use standart useradd command and only after pveum, but I am not sure. I see no reason to use PAM for other users except root ...
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!