[SOLVED] Ceph setup GUI, not able to set IP/CIDR?

Alexander Nilsson

New Member
May 26, 2019
See screenshot below, why is this field readonly? Is there some prequisite that I'm missing? Or is this a bug?

IF this is a bug, I imagine that there is a command line interface for this (like for everything else in proxmox)?

Thank you in advance for your assistance.

you should be able to select an ip/network from the drop down field... what does it show there ?
(the public network IP/CIDR)
On what pveversion -v ist the cluster?
Well, I have since then moved on by using the cmd line instead. NOW I have the following versions, I cannot say for sure what the versions were at the time, only minor upgrades since then I belive.

proxmox-ve: 6.0-2 (running kernel: 5.0.21-3-pve)
pve-manager: 6.0-9 (running version: 6.0-9/508dcee0)
pve-kernel-5.0: 6.0-9
pve-kernel-helper: 6.0-9
pve-kernel-4.15: 5.4-9
pve-kernel-5.0.21-3-pve: 5.0.21-7
pve-kernel-5.0.21-2-pve: 5.0.21-7
pve-kernel-4.15.18-21-pve: 4.15.18-48
pve-kernel-4.15.18-10-pve: 4.15.18-32
ceph: 14.2.4-pve1
ceph-fuse: 14.2.4-pve1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-2
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-5
libpve-guest-common-perl: 3.0-1
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.0-9
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.1.0-65
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-8
pve-cluster: 6.0-7
pve-container: 3.0-7
pve-docs: 6.0-7
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-7
pve-firmware: 3.0-2
pve-ha-manager: 3.0-2
pve-i18n: 2.0-3
pve-qemu-kvm: 4.0.0-7
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-9
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.2-pve1
Last edited:
vmbr0 (bridged with interface enp4s0f1) uses dhcp, was that reason for the problem?
If that's the interface for Ceph, yes. The wizard checks the IP configured with the public network in the ceph.conf, to prevent setting the wrong IP.

EDIT: this could be possibly made more dynamic.
Alright, I first thought it was kind of like that but with the option of specifying the IP in the box manually as well, and that it was just a bug that it didn't allow me to so. Also the DHCP thing didn't occur to me.

I guess I mark this as solved then.
ProxMox users, developers, et alia:

I am seeing the same problem, when I read Alwin say "If that's the interface for Ceph, yes" it did not immediately seem obvious to me how one determines or otherwise sets forth which interface Ceph should use? My vmbr0 is plugged into a trunk port on my switch and has no IP address assigned to it at all.

I did assign an IP address, gateway, netmask, etc.. to the interface and now Ceph seems to be able to get past that in the configuration. Am I to understand that Ceph is incapable of using a VLAN interface like "vmbr0.100" as it's interface? I had hoped to present a separate VLAN to Ceph for it to use as it's private network.

Last edited:
Please don't post on a 3-year-old thread. Open a new one and ideally provide some information right away. In this case, the contents of /etc/network/interfaces would be interesting.

Normally it shows up. I did a quick test and yes, a vmbr0.100 interface was shown in the configuration dialog for Ceph.

Alternatively, you can set up a dedicated VLAN interface with a name that is nice to read.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!