Ceph problem HEALTH_WARN_clock skew detected on mon.


Aug 5, 2019

I am facing the problem about ceph storage, we got this warning message in the portal, but i not sure how to fix the problem. I tired to install the ntp and start the service in all nodes, but it seem the problem didn't be solved.

On the other hand, i found that the storage showing is not match in the datacenter summary page and ceph page usage. I have attached the print screen about the problem.

Thank you.



  • datacenter_page.png
    34.9 KB · Views: 16
  • ceph_usage.png
    19.9 KB · Views: 17
Ceph is very sensitive when it comes to time differences between hosts, ceph will allow a minimal drift of 0.05 seconds before warning you about clock skews. It is therefor important to have all monitor hosts sync to the same, preferable local, time server. This should ensure that the drift is as low as possible. This warning will probably show up as well, when you restart one of your monitor hosts, but should go away when the host in question has synced properly.

The dashboard only shows storages selected in the preferences, depending on your version you can find them via the gear icon in the upper right or in the drop down menu of the user icon in the upper right as well.
[QUOTE = "parker0909, publicación: 261188, miembro: 76021"]
Gracias a todos. es muy útil para todas las sugerencias.

¿Funcionó para ti? Tengo un problema similar, tengo 3 nodos, que si se ven en la GUI, pero ceph no se levanta, tengo un error, conocen algún procedimiento para resincronizar y arreglar ceph.
  • Like
Reactions: pepex7
@sjmenesesn, please in English. Other we can't help you.
@sjmenesesn, please in English. Other we can't help you.

I had a similar problem, I have 3 nodes, that if they are seen in the GUI, but ceph does not get up (this is due to ntp synchronization of the nodes), I had an error, the procedure to resynchronize and fix ceph was to use the ntp chrony client , in this link it helps me, stop the other installed ntp services "systemctl stop systemd-timesyncd or /etc/init.d/ntp stop", I hope it helps someone, this worked perfectly for me.



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!