CEPH Installation Problem

camilocv

New Member
Jul 15, 2023
7
0
1
Hello, could you help me with the following problem, I had it working correctly and from one moment to another it stopped working, I have 4 pve, but pve2 didn't work for me so I deleted it and reinstalled it, a serious error never took me anymore I don't know what to do, can you help me please.

Proxmox GUI:
400 Parameter verification failed.
version: value 'pacific' does not have a value in the enumeration 'luminous, nautilus, octopus'
pveceph install [OPTIONS]
Connection to 172.12.10.102 closed.


Proxmox Consola

root@pve2:~# pveceph install
update available package list
start installation
Reading package lists... Done
Building dependency tree
Reading state information... Done
gdisk is already the newest version (1.0.3-1.1).
ceph-common is already the newest version (15.2.17-pve1~bpo10).
ceph-fuse is already the newest version (15.2.17-pve1~bpo10).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ceph : Depends: ceph-mgr (= 14.2.22-pve1) but it is not going to be installed
Depends: ceph-mon (= 14.2.22-pve1) but it is not going to be installed
Depends: ceph-osd (= 14.2.22-pve1) but it is not going to be installed
ceph-mds : Depends: ceph-base (= 14.2.22-pve1) but 15.2.17-pve1~bpo10 is to be installed
E: Unable to correct problems, you have held broken packages.
apt failed during ceph installation (25600)

root@pve2:~# pveversion -v

proxmox-ve: 6.4-1 (running kernel: 5.4.203-1-pve)
pve-manager: 6.4-15 (running version: 6.4-15/af7986e6)
pve-kernel-5.4: 6.4-20
pve-kernel-helper: 6.4-20
pve-kernel-5.4.203-1-pve: 5.4.203-1
pve-kernel-5.4.174-2-pve: 5.4.174-2
pve-kernel-5.4.73-1-pve: 5.4.73-1
ceph-fuse: 15.2.17-pve1~bpo10
corosync: 3.1.5-pve2~bpo10+1
 
Pacific is only available on Proxmox VE 7 AFAIR. So upgrade you cluster first. 6.4 is EOL since about a year now.
https://pve.proxmox.com/wiki/Upgrade_from_6.x_to_7.0
Hello, I do not want to change to version 7, since the version I had worked separately, I have the other pves in production and I do not want it to be affected by the change in version, since I do not handle proxmox very well, I do not want it to happen to it something wrong, I'll check the installation guide again https://pve.proxmox.com/wiki/Ceph_Nautilus_to_Octopus.

If I don't have a solution, I'll write again.
 
Wait, I just realized, that the GUI wanted to install Ceph Pacific? Are you running mixed major versions in your cluster? For example, Proxmox VE 7 and 6 nodes?
 
Parece que está intentando instalar paquetes de Ceph Octopus (15) en un sistema donde está instalado Ceph Nautilus (14).

¿Has seguido la guía para actualizar de Nautilus a Octopus en PVE 6? https://pve.proxmox.com/wiki/Ceph_Nautilus_to_Octopus

¿Tal vez las fuentes del paquete no se han adaptado en este nodo?
Un detalle que no se había informado es el siguiente:

root@pve2:~# ceph -v
ceph version 15.2.17 (694d03a6f6c6e9f814446223549caf9a9f60dba0) pulpo (estable)

Ya tengo la versión octopus, pero no me funciona.
 
Espera, me acabo de dar cuenta, que la GUI quería instalar Ceph Pacific? ¿Está ejecutando versiones principales mixtas en su clúster? Por ejemplo, ¿nodos Proxmox VE 7 y 6?
Si tengo 2 clústeres con la versión 6 y 2 clústeres con la versión 7, todo funcionaba bien antes, pero de repente todo dejó de funcionar.
 
Antes todo funcionaba perfectamente para mí, solo quería actualizar el pv2 porque aparecía en la configuración como desconocido, cuando lo desinstalé y lo reinstalé, aparecieron los siguientes errores.
 

Attachments

  • captura 2.PNG
    captura 2.PNG
    58.9 KB · Views: 3
  • Captura.PNG
    Captura.PNG
    44.5 KB · Views: 2
When I do a systemctl it tells me that all the services are disabled, I enable them and they are not enabled.
 

Attachments

  • systemctl.PNG
    systemctl.PNG
    56.4 KB · Views: 4

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!